The problem:

after having muted the System Sounds on the remote desktop machine, it shall unmute itself after several seconds. This pattern is persistent.

The physical setting:

I use my laptop at work, and use Remote Desktop Connection to access my desktop machine left in my apartment.

The software setting:

I have enabled Remote audio through the Remote Desktop Connection, and chose Remote audio playback --> Play on this computer. Thus, I get audio streaming on my laptop at work.

My attempt:

I have tried to find a way to mute System Volumes through a shortcut, and the following pages appears to be helpful:

  1. HowToGeek suggested to create a shortcut with the following executable command:

    “C:\Path\To\nircmd.exe” mutesysvolume 2

  2. The same source also points me to the shortcut for opening the Volume Mixer. %SystemRoot%\System32\SndVol.exe. Yet, I failed to find a stable way to mute System Sounds through AutoHotKey.

The problem for the suggested approach is that, on Windows 10, nircmd.exe no longer take the option "mutesysvolume 2" as designed. Instead of toggling the System Volumes, it is toggling the Device Volume. This is different from what the specs have suggested: http://www.nirsoft.net/utils/nircmd.html

  • Are you trying to mute the desktop computer or the laptop? Are you running anything on the desktop computer that might play around with the sound volume? What happens when you physically log in to the desktop machine and try to mute - does the sound reset there as well? – cdavid Sep 1 '16 at 16:53
  • @cdavid Apologzie for any confusion. I was trying to mute the System Sounds on the remote machine. When I directly log-on the "remote machine", the System Sounds has been muted; it was only through Remote Desktop Connection, that the System Sounds shall reset on the "remote machine". – llinfeng Sep 2 '16 at 3:21
  • @cdavid On the laptop machine that I run the Remote Desktop Connection session, I have also muted the System Sounds. All the rest devices/programs are not muted in the Mixer. – llinfeng Sep 2 '16 at 3:23
  • I have exactly the same problem. When I am connected via remote connection, muting system sounds does only work for few seconds. Seems like something is in control over the remote audio. – Zereges May 14 '20 at 11:49
  • I still don't have a solution, but here is what I just learned: Volume Mixer is actually specific to audio output devices. If you right-click on the speaker icon and open the "Mixer", you will see the names of the output devise appended towards the end of the title-text. It may help if you disable audio through the RDP setting? – llinfeng May 15 '20 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.