For some time, Microsoft has supported an option to remove the limit of 260 symbols for NTFS file name length.

The web is full of articles, describing what should be done.

  1. Hit the Windows key, type gpedit.msc and press Enter.
  2. Navigate to Local Computer Policy > Computer Configuration > Administrative Templates > System > Filesystem > NTFS.
  3. Double click the Enable NTFS long paths option and enable it.

However, I don't have such option. Please see the screenshot below:

screenshot

Am I missing some Windows update, or is it something else?

up vote 39 down vote accepted

The value has moved from NTFS directly into Local Computer Policy > Computer Configuration > Administrative Templates > System > Filesystem in the RTM version of the Version 1607.

enter image description here

enter image description here

  • This path: Local Computer Policy > Computer Configuration > Administrative Templates > System > Filesystem is missing for me. I have win 10 home premium but installed gpedit using superuser.com/questions/1018145/… – gyozo kudor Sep 8 '16 at 14:00
  • @gyozokudor - You can easily add the group policy editor to Windows 10 Home. – Ramhound Sep 8 '16 at 17:01
  • @Ramhound I've added it, my main problem is that the setting is missing. – gyozo kudor Sep 8 '16 at 19:31
  • @gyozokudor - Which is the reason, any group policy, has a corresponding registry key assosicated with it. Of course I will point out, that Windows Explorer, does not yet support the longer path names. – Ramhound Sep 8 '16 at 20:34
  • It's worth noting that most programs (Windows Explorer included) don't yet recognize the long file paths feature yet - robocopy is one of the few built-in exceptions that will copy directory files with the new feature – Coruscate5 Feb 28 '17 at 3:31

Modify applicable registry settings as listed in the below answers to potentially help resolve.

Know your Build Version

You can run WINVER to see what build your Windows 10 is but from what I gather with a little reading, the enabling of NTFS long paths is available as of Build 14352 and later, so check to see if your build release is older than that for an explanation why it's not an option from Group Policy otherwise.

enter image description here


Update - Newer Version Builds

WARNING: Before working in the Windows Registry, it is always a good idea to back it up first, so that you have the option of restoration, should something go wrong. This article shows the different ways to back up and restore the Windows Registry or its Hives.

It seems that the registry locations with some of the latest Windows 10 Anniversary updates have changed a bit to enable the Long Paths to help overcome the Windows API file paths and names that exceed a 255-260 character limit for such programs in Windows that can utilize this once enabled.

Registry Import Enabling Long Paths

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\FileSystem]
"LongPathsEnabled"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
"LongPathsEnabled"=dword:00000001

Optional Registry Value

The below registry key value changed when the option was made with the Local Group Policy editor to enable Enable Win32 long paths but the <SID> portions will likely be different per account defined with a profile, etc. on the local Windows 10 machine s plug those values in accordingly per what you see when you look there with regedit.

Windows Registry Editor Version 5.00

[HKEY_USERS\S-1-5-21-[<SID>-<SID>-<SID>]-1001\SOFTWARE\Microsoft\Windows\CurrentVersion\Group Policy Objects\{B0D05113-7B6B-4D69-81E2-8E8836775C9C}Machine\System\CurrentControlSet\Control\FileSystem]
"LongPathsEnabled"=dword:00000001

enter image description here

NOTE: Once you have these imported, you'll want to reboot to ensure the changes become effective just in case. It has been reported that these settings and even Group Policy settings that change these values and others do NOT always work with File Explorer or all Windows programs as those have to be coded to handle this explicitly from what I gather so this is not a 100% for sure will fix all issues but this is Microsoft's step forward moving to resolve this limitation.


Previous Version Builds

Warning: These below settings may not work for all builds of Windows 10 so you will need to backup, check, test, etc. but see the options above if you've not already.

Using the Registry instead at HKLM Level

  1. Hit the Windows key, type regedit and press Enter

  2. Go to the following Registry key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Policies

  3. On the right side, create a new 32-bit DWORD value named LongPathsEnabled. Set its value data to 1.

enter image description here

  1. Restart Windows 10

source


Using the Registry instead at HKCU Level

  1. Hit the Windows key, type regedit and press Enter.
  2. Navigate to: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Group Policy Objects{48981759-12F2-42A6-A048-028B3973495F} Machine\System\CurrentControlSet\Policies
  3. Select the LongPathsEnabled key, or create it as a DWORD (32-bit) value if it does not exist.
  4. Set the value to 1 and close the Registry Editor.

source

  • I have Version 1607 (OS Build 14393.105) and i still do not have the option there, either in the poilicy editor or in regedit. @magicandre1981 has the correct solution – Klas Mellbourn Sep 2 '16 at 11:10
  • For HKCU I don't have such a folder/key. Do I need one big folder named Group Policy Objects{48981759-12F2-42A6-A048-028B3973495F} Machine or did you just forget the slashes, something like this? Group Policy Objects\{48981759-12F2-42A6-A048-028B3973495F}\Machine – gyozo kudor Sep 8 '16 at 12:20
  • Winver says the following: Version: 1607 (OS Build: 14393.105) – gyozo kudor Sep 8 '16 at 13:21
  • 1
  • See the section in the answer Registry Import Enabling Long Paths for the registry settings that need applied for the newer versions of Windows 10 where using the gpedit.msc method is not available or if you just want to use that method instead of the Group Policy. The older version registry is at the bottom of the answer with applicable detail and the newer is up top but if you read it thru, it should be clear and not overly complicated. – Pimp Juice IT Jul 8 '17 at 4:56

1.Windows Key + R Key, type gpedit.msc and press Enter. 2. Navigate to Local Computer Policy > Computer Configuration > Administrative Templates > System > Filesystem.

enter image description here

  1. Double click the Enable NTFS long paths option and enable it.

enter image description here

  • 2
    you only repeated what was already posted – magicandre1981 Feb 14 '17 at 5:15

protected by Community Jan 17 '17 at 12:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.