15

I have a local IIS running, with a binding like www.dev.mydomain.com, the hostname is listed in an external DNS server and name resolution works fine.

When opening the site http://www.dev.mydomain.com in Microsoft Edge I get this message:

Hmm, we can't reach this page.

Make sure that you’ve got the right web address: http://www.dev.mydomain.com

The F12 Network Tab doesn't show anything.

What does work:

  • Using Firefox, Chrome, IE-11 and Command Line tools on the local machine
  • Using Edge from another machine on the local network
  • Using Edge on the same machine but with a different user
  • Using Edge with my user but using localhost or an IP address either 127.0.0.1 or 192.168.x.x

What I tried but not solving the problem:

  • Restarting the Network List Service and the Network Location Awareness service.
  • adding www.dev.mydomain.com to the hosts file.
  • using TLS and https://www.dev.mydomain.com
  • Using the same Windows Proxy settings as for the user which doesn't have the problem.

So this is a problem specific to one user and Edge, other programs or users don't have this problem.

Any ideas what else I can do to diagnose this?

Windows 10 - 1607 (14393.105)

  • So DNS points to your local machine? – sbrm1 Sep 1 '16 at 18:11
  • @sbrm1 - Yes, it points to a 192.168.x.x address and it works fine with ping, nslookup and all other browsers. – Peter Hahndorf Sep 1 '16 at 18:22
  • Is the URL externally accessible? – sbrm1 Sep 1 '16 at 18:41
  • 5
    MS Edge ignores your hosts file. Just one of it's many annoyances.If everyone ignores this browser, eventually it may just disappear. – user1751825 Dec 8 '16 at 4:01
  • 1
    I know you already said that DNS are working fine... but it sounds like a DNS problem... maybe you can "trick" only to test on your local hosts file and put that domain to resolve instead of 192.168.x.x to 127.0.0.1 to see what happens... and other test... did you try disabling your proxy settings? maybe doing this you can't surf the internet web, but the point is to try the localhost page. If it works... there is something related to proxy. – OscarAkaElvis Dec 16 '16 at 11:46
2

You need to enable the loopback address which is disabled by default in edge.

go to about:flagsand enable "allow local loopback"

be aware that there is a security implication in this but the risk is low.

enter image description here

|improve this answer|||||
1

I'm running the latest win 10 V 1809 build 17763.253.

I found a workaround on another thread, by adding the local IP range to the trusted sites, it works for me.

Second workaround is using the server name instead of the IP address.

Example: http://Computer-name/ which gets resolved to IP version 6 address.

Since this is bug only happens with MS EDGE and works fine with all other browsers, where is the official MS solution ?

Finally build 17763.316 fixed the bug, I removed the workaround and MS Edge can access all my local IP addresses 192.168.1.1 through 192.168.1.254 .

enter image description here

|improve this answer|||||
  • the official MS solution is that they are re-basing edge on the chromium engine... – David McGowan Jul 31 '19 at 16:54
1

This is a Windows security policy: applications in Windows Runtime (aka. UWP, including Edge) cannot access localhost by default.

Here are more details: https://blogs.msdn.microsoft.com/fiddler/2011/12/10/revisiting-fiddler-and-win8-immersive-applications/

Immersive applications (and IE11 on Win8/8.1, not on Win10) run inside isolated processes known as “AppContainers.” By default, AppContainers are forbidden from sending network traffic to the local computer (loopback). This is, of course, problematic when debugging with Fiddler, as Fiddler is a proxy server which runs on the local computer. The post went on to explain how the CheckNetIsolation tool can be used to permit an AppContainer to send traffic to the local computer. However, using CheckNetIsolation is pretty cumbersome—it requires that you know the AppContainer’s name or security ID, and you must configure each AppContainer individually. To resolve those difficulties, I have built a GUI tool that allows you to very easily reconfigure an AppContainer to enable loopback traffic. This tool requires Windows 8 and runs on the .NET Framework v4. When launched, the utility scans your computer’s AppContainers and displays them in a list view. Each entry has a checkbox to the left of it, indicating whether the AppContainer may send loopback traffic. You can toggle these checkboxes individually, or use the buttons at the top to set all of the checkboxes at once. Click Save Changes to commit the configuration changes you’ve made, or click Refresh to reload the current configuration settings.

You can got a GUI tool here to enable loopback traffic for UWP (written by others but with the same feature): https://github.com/tiagonmas/Windows-Loopback-Exemption-Manager

|improve this answer|||||
0

Have you tried updating "Hosts" file?

127.0.0.1 www.dev.mydomain.com 
|improve this answer|||||
-3

FIX #1

Go to services.msc and start the "DNS client service" and the problem should be fixed.

FIX #2

IF that isn't the solution, try this:

run regedit and go to

HK local machine>software>microsoft>windows nt>current version>network list>profiles>{GUID}"Category"

Find the profile for the network you are interested in and change the category value to 1 from 0.

FIX #2 EXPLANATION

Let me explain what it does: The fix seems to be making sure your network is private rather than public. For some reason this works and i cant explain it. I would also, like to point out, that if you are using a VPN this is the issue that may have caused it as there are reports of VPN software messing up settings in windows 10. Mostly, i am sure my first fix will help you in this case.

|improve this answer|||||
  • 2
    The OP says other user accounts of the same machine CAN access the site without problem. So, you machine-wide suggestions have no backing. – user477799 Jan 19 '17 at 19:00
  • @FleetCommand Can i get an opinion from OP not you please? – DeerSpotter Jan 19 '17 at 19:04
  • 1
    @DeepSpotter You can (and will) have the opinion of both of us. That's how this site works. If he marked your reply as the answer, I would retract my downvote. But I will be very much surprised. – user477799 Jan 19 '17 at 19:06
  • You should explain what changing the categroy value for the profile of the network does exactly. – Ramhound Jan 19 '17 at 19:17
  • 2
    As @FleetCommand said, both your changes are machine wide, and they don't make any difference, but thank you for trying to help. – Peter Hahndorf Jan 20 '17 at 7:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.