1
  • Host is Windows 7
  • Guest is Ubuntu 12.04

Everything was working fine before the VirtualBox upgrade.

Now, on boot, that ubuntu instance keeps waiting for network and when it finally boots ifconfig only shows the lo interface.

The strange thing is that another instance, ubuntu 14.04, with the same configuration, keeps working as normal.

/etc/network/interfaces

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet static
 address  10.90.90.4
 network  10.90.90.0
 broadcast 10.90.90.255
 netmask 255.255.255.0
 metric 1

ifconfig output: enter image description here

ifconfig -a output: enter image description here

VirtualBox network config: (host only network): enter image description here

Instance network config (eth0, bridged): enter image description here

Instance network config (eth1, host only): enter image description here

Any help?

== EDIT ==

Forgot to mention that eth0 and eth1 did show up on ifconfig after the upgrade, though they had not the RUNNING flag, and stopped showing after i regenerated the mac address in the vbox configuration window.

2

I think that regenerating the MAC Address of the NICs have now changed the interface name, edit this file "/etc/udev/rules.d/70-persistent-net.rules" you should see the eth0 and eth1, adjust here the MAC Address with the new generated by Virtual BOX. Probably there is also eth5 and eth6, remove them from the file.

|improve this answer|||||
  • This sounds like a possible approach. I'll try and let you know – brazorf Sep 1 '16 at 20:47
  • Thanks it worked and made my day. I didn't know that... each time i've tried to refresh the mac address a new interface was generated, i found up to eth7. Is that normal? – brazorf Sep 1 '16 at 21:28
  • Yes this is normal because udev use this file for keep trace of the Ethernet interface and when see a different MAC Address it will consider that you have installed a new Ethernet interface – DarkVex Sep 1 '16 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.