1

I'm on OSX El Captain and I would like to rename the file "usr/bin/openssl" into "usr/bin/openssl_old" (cause I want to update openssl) but when I try it says "operation not permitted" (even as root).

I tried :

-chmod ugo+w
-chmod ugo+w

-csrutil disable (this one says "csrutil: failed to modify system integrity configuration. This tool needs to be executed from the Recovery OS."

-chown root /usr/bin/openssl -R
-chmod 777 /usr/bin/openssl -R

please help !

  • you should have write permissions in /usr/bin to be able to rename the file – Romeo Ninov Sep 2 '16 at 9:45
  • I forgot to precise that I tried all commands below with /usr/bin and /usr – Amanite Laurine Sep 2 '16 at 9:47
  • Let me say it again: you need permissions to the directory, not the file. The filename IMHO is stored in to the directory record. If you exec ls -ld /usr/bin and you do not see yourself as owner or you are part of group or have 777 permissions you are not able to rename a file in this directory – Romeo Ninov Sep 2 '16 at 9:50
  • let me say it again : I tried to get permissions on directories /usr/bin and /usr – Amanite Laurine Sep 2 '16 at 9:58
  • 1
    use csrutil. As the error message you received indicates, you need to reboot to recovery mode (Cmd-R during power up), run csrutil disable, and then reboot again. – user4556274 Sep 2 '16 at 11:23
1

It's simply can be done following this steps:

  1. Boot your Mac in recovery mode (with holding Command+R);
  2. Check the status: csrutil status (System Integrity Protection (SIP));
  3. To disable protection run the following command: csrutil disable;
  4. Reboot the system again.

P.S. If you decide you want to enable SIP later, return to the recovery environment and run the following command: csrutil enable and reboot the system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.