I am unable to send/receive any emails in my MS outlook 2007. I am prompted with the following error

Can't move the items. The file <path>\<filename>.pst has reached its maximum size. To reduce the amount of data in this file, select some items that you no longer need, and then permanently delete them.

I looked up this link to understand more but my registry doesn't have the required entries.

Has anybody else faced the same problem ? If so can you please help me out ? Its urgent as i have a very important demo tomorrow. Thank you.


I'm assuming that you're not using the new Unicode pst file format in Outlook. This article explains how to create a new Unicode pst file and import your old pst file in to it.


Also, this link explains the size differences in the pst file formats:


And this link explains how to configure the file size limits:



Archive is your friend. You shouldn't need all that email in one PST file. Search crawls and it's generally information overload. I typically send everything for a year to an archive folder. So I have an archive for each year. I figure if I haven't touched it in a year I probably don't need it at my fingertips. And the archives are readily available in the tree in Outlook anyway.


There is a 2 GB maximum size limit if the the PST file is in the Outlook 97-2002 format. Outlook 2007 increased the PST size limit to 20 GB and Outlook 2010/2013 raise it to 50 GB. This is an internal limit to the PST format. If you've hit that limit, you'll have to move some email to another PST file.

More about Outlook size limits here: Outlook File Size Limits

If the registry setting aren't in your Registry, just add them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.