0

I couldn't get my USB 3.0 ProDock Ethernet port to connect to the Internet for my connected Windows 10 ThinkPad. However, plugging into my native Ethernet port on the back of the laptop worked.

I only use one port at at time, so despite warnings from Windows, I gave them both the same static IP address. But then, the dock quit working and it seems that I've tried every combination of setting IP addresses versus "Automatic" settings.

When I run ipconfig, I see that the docking station Ethernet adapter gets an autoconfigured IP address, even when I try to explicitly assign a Static IP address.

(The post here might be related, but it didn't mention the need for setting a static IP address.)

0

Just because you don't use both ports at the same time doesn't mean that you can still get by with having the same static IP address for both. Your system may simply be disabling one of them.

Though the following specifically works for my Windows 10 ThinkPad, I imagine it may be be instructive for others. (A special thanks to the IT professional in our building that helped me just now. This was his solution and it worked.):

  1. *Start with the Ethernet cable unplugged
  2. Go to Control Panel -> Network and Internet -> Network Connections
  3. Click on the icon for the normal Ethernet adapter
  4. Click on “Internet Protocol Version 4 (TCP/IPv4)" and change the IPv4 address and DNS settings to all be “Automatic”
  5. *Restart the computer
  6. Plug the Ethernet cable into the docking station
  7. Plug the USB 3 cable from the docking station into the laptop
  8. Repeat steps 2-4 above, except do it for the dock's Ethernet adapter, and instead of using "Automatic" settings, use the desired static IP address and DNS settings.

*Steps that may not have been taken previously that may have made the difference

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.