1

I have been doing work for two labs over the summer, which has required me to set up remote access to both computing clusters. One of them used x2go to connect to a MATE desktop and the other used NxMachine to connect to a KDE desktop, so I set them both up independently on my Windows laptop. The X2Go setup required only a password to connect to the server, while the NxMachine setup used a private key to connect via SSH.

Things ran fine for two months or so until Monday when I was unable to log in with the X2Go client, getting this message:

"The remote proxy closed the connection while negotiating the session. This may be due to the wrong authentication credentials passed to the server."

Since individual display sessions have gotten corrupted with X2Go before, I deleted the session files in C:/Users/MyUserName/.x2go/. I also used PuTTY to connect to my home directory on that server via ssh and deleted the session files from ~/.x2go/.

When I tried to log in again, I got the same error, and found that the session files were back in the .x2go folders.

Those session logs read:

"Loop: PANIC! The remote NX proxy closed the connection. Loop: PANIC! Failure negotiating the session in stage '7'. Loop: PANIC! Wrong version or invalid session authentication cookie."

For the first day, I was still able to connect to the other server using NxMachine, but now that session is also being refused with the error 107: connection refused.

Now I'm thinking that something is wrong with my authentication keys? However, I honestly have no idea how to check that or fix it if it is the case, so I'm kind of stuck here.

(As you can probably tell, I'm pretty inexperienced with all of this and could use any help that you all can give me on this, even understanding the logs and the error messages. If you need any extra info, please let me know.). Thanks!

3

I came across this post while looking for a resolution to the same issue.

I'm adding my solution for others who may be in a similar situation.

I simply reinitialized the x2go database:

x2godbadmin --createdb
0

I had the same error message but reinitializing the database had no effect.

I had to uninstall and reinstall the x2goserver package.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.