4

i'm connected to the WiFi of my house, but like once a day the connections drops and i'm not able to connect again. I've tested in other devices and the connection/internet is working fine.

I've tried doing:

#sudo ifconfig wlp5s0 down
#sudo ifconfig wlp5s0 up

and:

#sudo service network-manager restart

But that doesn't work. The system log say the following:

Aug 31 09:34:16 usermsi NetworkManager[1061]: <info>  [1472657656.3590] device (wlp5s0): supplicant interface state: disconnected -> scanning
Aug 31 09:34:17 usermsi kernel: [ 1206.730731] wlp5s0: authenticate with FF:FF:FF:80:2a:83
Aug 31 09:34:17 usermsi NetworkManager[1061]: <info>  [1472657657.3169] device (wlp5s0): supplicant interface state: scanning -> authenticating
Aug 31 09:34:17 usermsi kernel: [ 1206.763354] wlp5s0: send auth to FF:FF:FF:80:2a:83 (try 1/3)
Aug 31 09:34:18 usermsi kernel: [ 1207.846260] wlp5s0: send auth to FF:FF:FF:80:2a:83 (try 2/3)
Aug 31 09:34:19 usermsi kernel: [ 1208.786318] wlp5s0: send auth to FF:FF:FF:80:2a:83 (try 3/3)
Aug 31 09:34:20 usermsi kernel: [ 1209.786338] wlp5s0: authentication with FF:FF:FF:80:2a:83 timed out
Aug 31 09:34:20 usermsi NetworkManager[1061]: <info>  [1472657660.3734] device (wlp5s0): supplicant interface state: authenticating -> disconnected

It seems that the network manager found the SSID, try to connect but is not able to do it.

Linux Mint 18 Sarah

       *-network
            description: Wireless interface
            product: RTL8723AE PCIe Wireless Network Adapter
            vendor: Realtek Semiconductor Co., Ltd.
1
  • My wifi was working great in 17. I suspect a regression bug in kernel since 18 upgraded the kernel. Very frustrating. This only happens at home. I have bought three wireless routers (other forums blamed old routers -- this is not the case). I just want this fixed without some smart ass telling me to downgrade to Mint 17.
    – RyanNerd
    Sep 20, 2016 at 10:54

3 Answers 3

3

We have the same problem on one of our laptops; this laptop is relatively new (only a few months old), using Linux Mint 18.1 - never had another OS, and like Dušan Šušić stated, the only way we've been able to 'fix' this is by restarting Network Manager.

This happens at home and all public access points used so far. I could be wrong but it seems to have gotten worse when we add machine to the network last week. We never have more than 4 connected simultaneously, (1 is hardwired), the Router is designed to handle 8 simultaneously, and the work load is quite light.

I wrote an executable attached to an alias (called 'fixwifi', lol) that I use whenever this occurs:

#!/bin/bash
sudo systemctl stop NetworkManager.service
sudo systemctl start NetworkManager.service &
disown
clear

It serves as a temporary 'fix', as the only other way to 'solve' this problem is to reboot until the connection is made. Network Manager frequently doesn't even have the option to setup a connection when this occurs or turn the wifi on / off. (The slidebars are all removed).

Interestingly enough, we are ALSO using a Cisco access point, and this has been occurring with several different versions of the Linux 4 Kernel...


System

Host: [CENSORED] Kernel: 4.4.0-71-generic x86_64 (64 bit gcc: 5.4.0)

Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.2)

Distro: Linux Mint 18.1 Serena

Machine: System: Dell (portable) product: Inspiron 3558 Mobo: Dell model: 0342JP v: A00 Bios: Dell v: A11 date: 09/06/2016

CPU: Dual core Intel Core i5-5200U (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8779 clock speeds: max: 2700 MHz 1: 2346 MHz 2: 2200 MHz 3: 2200 MHz 4: 2212 MHz

Graphics: Card: Intel Broadwell-U Integrated Graphics bus-ID: 00:02.0 Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)

Resolution: 1366x768@59.79hz

GLX Renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)

GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes

Audio: Card-1 Intel Wildcat Point-LP High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel bus-ID: 00:03.0 Sound: Advanced Linux Sound Architecture v: k4.4.0-71-generic

Network: Card-1: Intel Wireless 3160 driver: iwlwifi bus-ID: 06:00.0 IF: wlp6s0 state: up mac: Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 07:00.0 IF: enp7s0 state: down mac:

Drives: HDD Total Size: 5001.0GB (84.9% used) ID-1: /dev/sda model: WDC_WD10JPVX size: 1000.2GB ID-2: USB /dev/sdb model: My_Book_1235 size: 4000.8GB

Partition: ID-1: / size: 909G used: 786G (92%) fs: ext4 dev: /dev/sda1 ID-2: swap-1 size: 8.49GB used: 0.00GB (0%) fs: swap dev: /dev/sda5

RAID: No RAID devices: /proc/mdstat, md_mod kernel module present

Sensors: System Temperatures: cpu: 48.0C mobo: 25.0C Fan Speeds (in rpm): cpu: N/A

Info: Processes: 204 Uptime: 38 min Memory: 1447.4/7893.9MB Init: systemd runlevel: 5 Gcc sys: 5.4.0 Client: Shell (bash 4.3.461) inxi: 2.2.35

2
  • I reainstalled mint after several months using Windows but sadly I'm having the same issue. And this script didn't work for me
    – Mariano L
    Jul 11, 2017 at 15:39
  • This solution works for me in Linux Mint 19.3
    – Kane
    May 22, 2020 at 20:02
0

I've found this solution and worked for me:

https://forums.linuxmint.com/viewtopic.php?t=204172

1. sudo apt-get install linux-headers-generic build-essential git

2. git clone https://github.com/lwfinger/rtlwifi_new

3. cd rtlwifi_new

4. make

5. sudo make install

6. sudo modprobe rtl8723be 
rtl8723be was my wireless ..change rtl8723be to your model 
0

But you can reach your websites, I presume? Otherwise you can try:

service network-manager stop rm /var/lib/NetworkManager/NetworkManager.state service network-manager start

Found this on AskUbuntu. Works for me on Linux Mint 18.2 MATE.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.