1

So I just recently upgraded my system to Windows 10. Funny thing was the wireless network capabilities were disabled and I was not even able to turn on the Wi-Fi. I reinstalled again and did a lot of searching but nothing worked. I got fed up and closed my lid and after some time when I opened it back, the system just woke up from a sleep and voilà! the Wi-Fi was turned on.

Basically I upgraded to Windows 10. Wi-Fi won't turn on. Put the system to sleep and after wake up, the Wi-Fi works.

This works for me currently but I feel so dumb that I have to put my system to sleep every time I boot it up.

I am using Dell i7559, if that matters, and all my drivers are up to date.

I have already tried all the solutions suggested at https://communities.intel.com/thread/97595

How can I make my Wi-Fi work without needing this kludge?

  • Don't keep your drivers "up-to-date". Try installing older versions, especially if possible the ones that came with your system. These often work better. – PulseJet Sep 17 '16 at 19:56
  • Yeah tried rolling back my driver as well. The driver which came with system also failed. – takirala Sep 17 '16 at 19:57
  • 1
    Have you tried : (1) Deleting the WiFi in the Device Manager and reboot? (2) An offline upgrade of Windows 10 to itself (using a downloaded ISO) then redoing (1) above? – harrymc Sep 18 '16 at 9:31
  • Yes. Tried deleting the wifi adapter from device manager and booted up from the iso. Still it has to go back to sleep and wake up to work again. – takirala Sep 20 '16 at 14:28
  • 1
    This seems like a relatively recent computer. If it is still under warranty, you might use it to get professional help. – harrymc Sep 22 '16 at 19:42
0

This is a problem that has appeared out of nowhere.

You have tried to update all drivers, both via Windows Update and the Dell drivers for the Inspiron 7559, but nothing worked.

I believe that as the software is up to date, this leaves only hardware. This fits the fact that the equipment that has worked flawlessly for quite some time suddenly stopped working correctly.

The explanation for the WiFi card to only work after waking from sleep, would then be that the problem arrives on a cold boot, then is fixed when the wake resets the now-warm card.

The solutions for a hardware problem are not many :

  1. Live with the fact that you need to enter sleep for it to work, until a more serious failure will force you to take some other measure.
  2. Replace the internal WiFi card (not feasible if soldered to the motherboard).
  3. Use an external WiFi adapter.
  4. If the computer is still under warranty, use it to get professional help.

If point 4 is still applicable, I would use it first before the warranty elapses.

|improve this answer|||||
0

I too had this problem with my pc (HP n004tx). It seems to be a problem with early versions of Windows 10. Many unofficial Windows user had similar problem.

All they had to do was 'disable' and then 'enable' the 'WiFi-Adapter' in 'Network Adapters' setting in Device manager of your system.

|improve this answer|||||
  • I tried disabling and enabling. As well as uninstalling and installing again. Without going back to sleep and waking up again, wifi doesn't want to work. – takirala Sep 20 '16 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.