11

After the Anniversary Update, there's a new entry running under Event Trace Sessions on Windows 10 called UserNotPresentTraceSession.

To check this, open the Performance snap-in and expand Event Trace Sessions.

The funny thing is that you don't have the option to disable this under Startup Event Trace Sessions like you have with all the other entries.

4

Looking at the properties it captures Power related data (Sleepstudy, AdaptiveStandby) when no user is actively using the device.

Logger Name           : UserNotPresentTraceSession
Logger Id             : 14
Logger Thread Id      : 0000000000000354
Buffer Size           : 64
Maximum Buffers       : 24
Minimum Buffers       : 2
Number of Buffers     : 2
Free Buffers          : 1
Buffers Written       : 1
Events Lost           : 0
Log Buffers Lost      : 0
Real Time Buffers Lost: 0
Flush Timer           : 0
Age Limit             : 0
Log File Mode         : Circular PersistOnHybridShutdown NoPerProcessorBuffering
Maximum File Size     : 2
Log Filename          : C:\Windows\system32\SleepStudy\UserNotPresentSession.etl
Trace Flags           : "Microsoft-Windows-UserModePowerService":0x2c:0x4+"Microsoft-Windows-Kernel-Power":0xe03:0x4
6
  • Thank you. And apparently you cannot disable it, but can delete it.
    – Ryakna
    Sep 7 '16 at 8:41
  • On my build 14393.969 test system even if deleted the UserNotPresentTraceSession reappears after a reboot. I have no use for this tracing and want to reduce system volume writes. Any ideas how to rid the system of it entirely so that it doesn't come back?
    – NoelC
    Mar 21 '17 at 3:53
  • @NoelC stop trying to damage your system. leave it running it doesn't impact you, it helps to trouble shoot power saving issues Mar 21 '17 at 16:29
  • 2
    Thanks, but I prefer control.
    – NoelC
    Mar 22 '17 at 16:52
  • @NoelC ask on msfn here you all destroy your Windows. maybe someone else helps you Mar 22 '17 at 16:53
12

I had a problem with "UserNotPresentSession.etl". It was overloading my SSD (100% activity, ~50MB/s writing) for example when I was playing GTA V. I didn't find any information how to disable it, but I found this reddit post: https://www.reddit.com/r/techsupport/comments/524d4s/disk_usage_raising_to_100/d7h7xwt/ where somebody described the same problem.

I found a solution for this problem, by setting "UserNotPresentSession.etl" to Read-only.

  1. Go to: "C:\Windows\System32\SleepStudy".
  2. Click the right mouse button on file: "UserNotPresentSession.etl" and then "Properties" from the list.
  3. Check "Read-only" checkbox and save changes.
  4. IMPORTANT: Restart your computer.

After that the disk is not longer abused. I experienced this problem on Windows 10 builds 14393 and 15063.

I hope this post will help people with the same issue.

1
  • I'm glad i wasnt the only one who noticed this. Thanks :) May 22 '17 at 14:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.