1

My server seems to have an issue where whenever I do a disk transfer Disk Transfer speeds are going at an expected rate, and my RAM usage begins to climb. Once my RAM usage hits ~50% the transfer rate begins to drop to about ~9MB/s, and my RAM usage stays at a constant ~50% usage, this has been making me scratch my head for the past week.

The server was initially only installed with ESXI 6.0, I created a VM and started to do some network transfer to it and noticed that the transfer rate would slow down to about 11MB/s, at first I thought it was a SMB issue, was not the case, I tried different switches, no luck, same issue. I then tried a disk transfer on the local VM's disk, and I saw the same thing.

I tried switch the VM's controller didnt work, i tried multiple OSs, but to no solution. I then removed ESXI and install Windows7, same issue, Windows Server 2012 and 2008, same issue.

I then upgraded the firmware of the SAS controller, still no luck.

I am stuck, this is nothing else that makes sense to me. The only issue I could think would be the SAS controller itself taking up the RAM, which doesnt make any sense to me and I dont want to buy a controller and it not be the solution.

At this point I need any help i can get, thank you

Server Specifications:

BOARD : SuperMicro H8DG6-F
CPU : 2x AMD 6272
RAM : 64GB DDR3 PC3-10600R (16x4GB)
HDD : 2 x 1TB Seagate, 2 x 1TB WD Blue
CONTROLLER : Integrated LSI 2008 SAS2 Controller
CHASSIS : SuperChassis 826A, With SAS826A Backplane
  • Sounds like your RAID card is using some sort of shared memory architecture. A quick Google of "Integrated LSI 2008 SAS2 Controller" did suggest some of this to be true. Do you have access to another RAID card? Unfortunately be prepared to lose data trying this or use different drives. – adampski Sep 3 '16 at 17:03
  • I have no data on the drives, I just got the server a week ago, so i was luckily in the early setup phase when I discovered the issue. I do not have a controller handy, but I can purchase one. This is my first time using a SAS controller, so i guess i didnt know how to research this issue. Thank you for your help – Justin Sep 3 '16 at 17:18
  • I just had a look at your motherboard on SuperMicro's website it seems to suggest that the LSI 2008 SAS2 Controller really is 'integrated' as in it's not an expansion card. If this is the case, try updating all firmware that you can get your hands on for the motherboard & controller (if seperate). If it is not the case and the controller is an expansion card, try just plugging the SAS drives directly to the mobo see how it performs then. – adampski Sep 3 '16 at 20:30
  • Updating the controller's BIOS to the IMR version should help. But this is a 6 year old controller design (533MHz, single core CPU, no write cache) it's going to perform poorly no matter what you do. – David Schwartz Jun 11 '17 at 17:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.