7

For programs such as: Skype, Chrome, ditto. . . .

  • The Windows 10 firewall It seems that each time I reboot the PC I have to accept a pop up for Windows Firewall to allow the app access. Each time I reboot, I have to do this again when it prompts.

Is there a way for me to prevent this from occurring so the Windows Firewall knows that I allow these apps access so I can just use them?

EDIT screenshot of the alert: enter image description here

4
  • i am quite sure it was some sort of anti virus software / maleware spyware removal software that I installed. Resetting all the rules every couple seconds. Now i once had the feeling I was attacked so i installed a bunch, but dont remember which one cause the issue. I got a new computer last december, so i cannot give more input on this i fear – Toskan Apr 3 '17 at 16:00
  • i upvoted your answer for the effort, I dont think it solves the question though, as the rules are reset each couple seconds – Toskan Apr 3 '17 at 20:33
  • actually it is not malware that caused that problem on my computer, but the anti malware software I installed. – Toskan Apr 13 '17 at 20:50
  • Okay, just let me know when you write up the correct answer that answers your question and I'll look it over. Thanks for the chat! – Pillsbury IT Doughboy Apr 14 '17 at 2:18
5

Allow Apps through Windows Firewall with Command Line

You can setup a Windows Firewall rule with NETSH to allow a specific application inbound and/or outbound on any profile from an elevated command prompt run as administrator with the below syntax or something similar:

Confirm the full explicit paths of the programs you want to allow incoming and outgoing thru the Windows Firewall for all applicable profiles, and set them correctly for each where needed in program="<value>" with the value needed there being the full path e.g. C:\path\path\app.exe.


Setting up a Windows Firewall rules to allow an app inbound and outbound will help prevent the prompting of the Windows Firewall you may get each time an app is launched and asked you to allow it.

Allow App Outbound

netsh advfirewall firewall add rule name="Skype Out" dir=out action=allow program="C:\Program Files\Skype\Phone\Skype.exe" enable=yes profile=domain,private,public

netsh advfirewall firewall add rule name="Chrome Out" dir=out action=allow program="C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" enable=yes profile=domain,private,public

Allow App Inbound

netsh advfirewall firewall add rule name="Skype In" dir=in action=allow program="C:\Program Files\Skype\Phone\Skype.exe" enable=yes profile=domain,private,public

netsh advfirewall firewall add rule name="Chrome In" dir=in action=allow program="C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" enable=yes profile=domain,private,public

Further Resources

3

Allow Apps thru Windows Firewall with Advanced Security GUI options

You could also go to wf.msc and then add a rule to tell the Windows Firewall to allow a specific app inbound and/or outbound on all profiles.

Instructions

  1. Press enter image description here +R, type in wf.msc and then press Enter.
  2. Click on Inbound Rules and then click on New Rule... to the right

    enter image description here

  3. In the Rule Type options window check the Program option and then press Next

    enter image description here

  4. In the Program options window in the This program path field either browse find or specify the full explicit path of the exe of the apps file which you want to allow through the Windows Firewall and then press Next

    enter image description here

  5. In the Actions options window ensure the Allow this connection option is selected and then press Next

    enter image description here

  6. In the Profile options window ensure that all three options of Domain, Public, and Private are selected and then press Next

    enter image description here

  7. In the Name field type in a name for the new rule and then press Finish

    enter image description here

  8. You should now see the new rule you just created. You could then click on the Outbound Rules option and follow the same steps 1 - 8 as listed above for the app you need to allow outbound connections.

    enter image description here

Just follow these steps for allowing all the incoming and outgoing app rules you need and scale accordingly to prevent Windows Firewall from prompting after each reboot.

2
  • actually still happens on each boot, i did inbound and outbound – Toskan Sep 25 '16 at 1:52
  • can it be that it does not get saved for some reasons? i cannot see the rules any more when i open wf.msc – Toskan Sep 27 '16 at 5:40
0

To whoever in future it may concern. (about NETSH method in previous answer by IT solution , WIN 7)

If you have app listening for connections and Windows still keeps nagging about program add "edge=yes" parameter for inbound direction.

https://technet.microsoft.com/en-us/library/dd734783(v=ws.10).aspx?

So complete rule command from example would become:

netsh advfirewall firewall add rule name="Skype In" dir=in action=allow program="C:\Program Files\Skype\Phone\Skype.exe" edge=yes enable=yes profile=domain,private,public

For outbound rule there is no "edge" parameter. After adding in and out rule Windows firewall should stop asking user about permission.

1
  • You should quote and cite all relevant information in your answer itself. Your answer by itself, should have all relevant information, to answer the question. This currently is not the case. – Ramhound Nov 29 '16 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.