1

Trying to connect to Windows Server 2012 VPN over L2TP.

Server configured to support L2TP using "custom IPSec policy" PSK. All authentication methods are checked off.

Clients are configured to connect with L2TP and is using the PSK for authentication. Tested with settings [Encryption is optional accepting PAP, CHAP, or MS-CHAPv2] and [Encryption is option accepting EAP-MSCHAPv2].

The server has a public IP and all traffic is being routed to it for testing purposes, nothing is being filtered out. I am using two clients, one using it's public IP from another network and one on the same subnet as my server trying to use its private IP. All clients and the server have their firewalls completely disabled. Neither client can use the VPN and both are Windows 10.

I have verified all L2TP miniports are working in Device Manager.

Connection attempt errors:

Client error: Error 789: The L2TP connection attempt failed because the security layer encountered a processing error during the initial negotiations with the remote computers.

Errors in RRAS logs: None(RRAS is configured to log all events)

  • How do you connect to the Internet? You say you have a public IP directly connected but what hardware sits between the server and your ISP connection? – Kinnectus Sep 5 '16 at 10:57
  • Additionally, have you tried using the Server 2010 VPN wizard? It should do everything for you... Finally, I would recommend you choosing one tunnel type and sticking to it... SSTP if all your clients are Windows-based because this just works (and works across problematic scenarios such as cafes, airports etc.). – Kinnectus Sep 5 '16 at 11:07
  • I've updated the post with more relevant information. Apologies for the confusion. – Needs More Documentation Sep 6 '16 at 6:29
  • vpnranks.com/how-to-fix-vpn-connection-error-789 - see the last "try this" on this link. About enabling and starting a couple of services on your clients. – Kinnectus Sep 6 '16 at 6:59
  • I restarted the RRAS service and verified the other services in the article were running. I then tried restarting those as well. Then I just rebooted the whole server. No luck yet. FYI, based on the settings I don't think I need them but in case I am wrong I do not have any certificates to identify my clients or server. – Needs More Documentation Sep 6 '16 at 7:41

protected by Community Oct 20 '16 at 16:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.