2

There are several methods you find if you google

  1. Setting the BITS Start Key under HKLM\Services\CurrentControlSet to 4
  2. Run "sc stop bits"
  3. Run mscongig & go to startup and uncheck Background Intelligent Transfer Service.

I tried all of these but none of these prevent BITS from downloading stuff in the background.

Normally, it's not so bad, but I had a Windows Update download stop in between when my internet connection went down. When my internet connection came back up, the BITS choked up my internet connection downloading stuff continously. You will see it in Task Manager Performance Tab Monitor Resources as hostsvc -k netsvcs.

1

4 Answers 4

1

Nothing disables BITS permanently, it keeps getting enabled after few days. But you can set bandwidth consumption of BITS to 0kbps and restrict it from eating up internet speed.

This is the only trick I found to control BITS and it worked perfectly for me.
So here you go,

  1. Open start menu(or press windows key), type gpedit.msc(Edit group Policy) and open it.
  2. Navigate to Computer Configuration > Administrative Templates > Network > Background Intelligent Transfer Service (BITS)
  3. Edit(double click) Limit the maximum network bandwidth for BITS background transfers.
  4. Now select Enable and change Limit background transfer rate(kbps) to to 0 or some lower value like 2. Remember you need to set this at 2 places on same screen, one for scheduled time and one for all other times.

That's it. BITS will now use only the bandwidth you have specified.

1
  • Very sneaky. I like it. Nov 12, 2020 at 3:21
0

None of the above methods worked. What actually worked was setting my Wifi Connection as a metered connection.

The way to do this is

  • Go to Network and Settings->Wifi
  • Click on your connection
  • Click on Advanced options below the list of your Wifi Connections
  • Set Metered Connections to On.

This seems to be the only thing which can stop BITS from download stuff in the background.

BITS had made my laptop unusable for a few hours before I found this workaround.

0

if you don't want it to start anymore you can

  1. open the services (search in Cortana for services)
  2. look for Background Intelligent Transfer Service and double click it
  3. change startup type to disabled

if you want to prevent it from connect to the internet

  1. when it start right click from task manager and select open file location and copy it (i think but not 100% sure it's "C:\Windows\System32\bitsadmin.exe")
  2. open windows firewall with advanced security (search for it too)
  3. choose inbound rules from left sidebar
  4. choose new rules from right sidebar
  5. select program and click next
  6. choose this program path and paste the path you got from step 1 and click next
  7. choose block this connection
  8. check all and click next
  9. write any name but you will need it if you wanna run it again later
  10. choose outbound rules from left side bar
  11. repeat steps 4-9
3
  • Disabling BITs from Services.msc is no longer allowed in Windows 10. All options are greyed out.
    – user93353
    Sep 6, 2016 at 4:11
  • what version of windows 10 do you have ? cuz with me windows 10 pro version 1607 build 14393.105 it does work
    – Robert
    Sep 6, 2016 at 10:53
  • W10 Pro 2004 allows it. Not that I'd give it any trust that MS will allow it to stay disabled for long, of course. Nov 12, 2020 at 3:20
0

So i tried all of the methods on this thread, and none of them worked. What ended up working for me was taking ownership of the file and moving it from the system 32 folder. However, I expect that this is a temporary solution at best.

3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .