I bought this lcd screen http://www.waveshare.com/wiki/10.1inch_HDMI_LCD_(H)_(with_case) for my raspberry pi 3.

This screen has a usb capacitive touch input.

I installed kodi 15 under raspbian os using following command:

 sudo apt-get install kodi

Touch works with raspbian os. However it does not work under kodi installed under raspbian os. It does not work with OpenElec as well.

I tried it with Kodi installed in Windows 10. The touch functionality works in Kodi in this case.

On issuing following command:


I get Microelectronics Joystick in FS Mode.

How do I make it work in Kodi installed in raspbian os?

Update: I see mouse cursor on the middle of the screen when I touch to upper left part of the screen. My resolution is off as well.

I have added below to my config.txt but with no success for getting the resolution correct:

hdmi_cvt 1024 600 60 6 0 0 0

I had the exact same issue with this screen - after a few days of frustration, i found a fix for the touchscreen - see below.

I wanted just OSMC rather than Raspbian, but this should still work. The author has another tutorial for Xbian.

I had no luck with the config.txt either - but i was able to go into the Kodi settings and change the video output calibration - which worked well enough for me.

The touchscreen was only working in the top left corner too - after some research i found this;

Follow the steps here: http://markamc.traki-iski.co.uk/raspberry-pi-2-osmc-egalax-touchscreen

By using a modified version of ts_calibrate for touchscreen calibration and python utility uinput-mapper, it’s possible to generate a user-input device even which handles the calibration transformations and gives additional BTN_LEFT/RIGHT functionality within KODI on the Raspberry Pi.

It's a rather long process - but i ended up with a perfect 10.1 inch touchscreen for my car media center :)

| improve this answer | |
  • i had tried this tutorial before as well which did not work but I see there is an update to this tutorial. Will give it a shot. thanks – sonam Jan 13 '17 at 13:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.