0

I tried asking the question at askubuntu but didn't get any answer so I am asking it here.

I am using a pc with dual boot Windows 10 and Ubuntu 16.04. each time I use ubuntu and shutdown and then login to windows the Ethernet doesn't work upon troubleshooting it shows error one or more network protocols are missing on this computer .

I found the solution to the above is running the command netsh winsock reset on command prompt.

However I have to restart windows again for the command to take effect which is a pain,so I am looking for a permanent fix.

summary : use ubuntu -> shutdown ubuntu-> login windows -> ethernet doesn'twork -> 
          fix via cmd -> have to restart windows again(pain)
  • try these suggested fixes: appuals.com/best-fix-one-or-more-network-protocols-are-missing Assuming you have one, is your cable modem by chance an "Arris Interactive, L.L.C. tm602g"? – Argonauts Sep 6 '16 at 4:20
  • @Argonauts i have a Realtek card. i tried these methods but no success – venky__ Sep 6 '16 at 5:11
  • You have a realtek cable modem? Also - since one of the items on the list was your current workaround, the assumption was that some of these setting changes would result in at least a temporary resolution as does the network stack reset with netsh. If you provide the results from trying those things, good and bad, someone may be able to assist. Disabling and enabling the NIC did nothing? – Argonauts Sep 6 '16 at 7:22

protected by Journeyman Geek Nov 14 '17 at 6:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.