2

The problem

When being logged out, I can see the Microsoft web pages. I have trouble accessing Microsoft websites after signing in with my Windows Live ID. For many pages I try to access, it redirects me to an error page. However, I need to login in order to access some resources, e.g. the Windows 10 Insider builds (related SuperUser question).

My login

AFAIK, I have only one Microsoft Live account and I maintain my password with KeePass since years, so it's unlikely a credentials issue. There's no error message about invalid username or password. I have received emails from Microsoft on that account lately (June or so). In addition, I was able to update my Visual Studio Community edition license using that account today. All in all I'm quite sure it's the correct email address and password that I use to log in.

Environment

My default OS is Windows 7 x64 SP1 Professional and my browser is Firefox 48.0.2 with Adblock Plus and HTTPS Everywhere installed. I don't need a Proxy and I have not enabled proxy settings. My virus scanner is ESET NOD32 9.0.402.0.

While the Windows language is English, my keyboard is German (default) but I can switch to English and Chinese. I notice that Google searches often bring me to German Microsoft pages, e.g. the German version of MSDN. I'm not sure if this relates to the issue.

I have tried others (see below).

I am connected to the Internet via Ethernet (private 192.x network) that goes over an unmanaged switch directly into a DSL router (Fritz!Box 7362SL). My line is 50 MBit/s downstream and 10 MBit/s upstream. A speed check roughly confirms that. There's nothing noticeable about the Internet connection in general. E.g. I can access my server via SSH, StackOverflow works well etc.

C:\Users\Thomas>nslookup microsoft.com
Server:  fritz.box
Address:  fd00::ca0e:14ff:fed7:9909

Non-authoritative answer:
Name:    microsoft.com
Addresses:  23.100.122.175
          23.96.52.53
          104.43.195.251
          191.239.213.197
          104.40.211.35

Issue details

When I enter microsoft.com into my browser's address bar, it redirects me to

https://www.microsoft.com/library/errorpages/smarterror.aspx?aspxerrorpath=/de-de/

On that error page, I can click various links that also generate an error:

"Download Center" (http://www.microsoft.com/en-us/download/default.aspx) 
--> https://www.microsoft.com/library/errorpages/smarterror.aspx?aspxerrorpath=/en-us/download/
"All Microsoft Sites" (http://www.microsoft.com/en/us/sitemap.aspx)
--> https://www.microsoft.com/library/errorpages/smarterror.aspx?aspxerrorpath=/en-us/sitemap.aspx
"Microsoft Worldwide" (http://www.microsoft.com/en-us/WorldWide.aspx)
--> https://www.microsoft.com/library/errorpages/smarterror.aspx?aspxerrorpath=/en-us/worldwide.aspx

Most important to me at the moment is the Windows 10 ISO download link that does not work as well

https://www.microsoft.com/en-us/software-download/windowsinsiderpreviewadvanced
--> https://www.microsoft.com/library/errorpages/smarterror.aspx?aspxerrorpath=/en-us/software-download/windowsinsiderpreviewadvanced

Some other pages work:

"PC Hardware" (https://www.microsoft.com/accessories/en-us)
"Security Essentials" (http://windows.microsoft.com/en-US/windows/products/security-essentials)

Question

How to fix it? Of secondary interest: the technical details on how this can happen and learn about other possibilities of troubleshooting such an issue.

I have tried

The question I can't access any Microsoft website did not reveal things that I considered as interesting.

On the same system:

  • logging out and signing in again
  • typing the email and password manually instead of having KeePass type it
  • disabling Adblock Plus in Firefox
  • disabling HTTPS Everywhere in Firefox
  • disabling ESET NOD32 for a while ("pause protection")
  • using Google Chrome 52.0.2743.116 m
  • using Google Chrome 53.0.2785.89 m
  • using Internet Explorer 11.0.9600.18426 (Update version 11.0.34)
  • using Opera 39.0.2256.48
  • disabling IPv6 support of the Ethernet LAN adapter
  • switching the User Agent to iPhone 3.0
  • looking at C:\Windows\System32\drivers\etc\hosts - it does not contain any entries
  • checking the proxy settings - it's "no proxy"
  • uninstalling ESET NOD32 and rebooting the system

In a VMWare 12.1.1 build 3770994 VM with Windows 7 x64 SP1 Home Premium:

  • no Adblock Plus installed
  • no HTTPS Everywhere installed
  • no virus scanner installed
  • Internet Explorer 10.0.9200.17609

In a VMWare with a modern.ie VM Windows 8.1 Enterprise:

  • Internet Explorer 11.0.9600.17416 (Update version 11.0.14)

In the Firefox network analysis I see the following when I enter "microsoft.com" in the address bar:

Using Wireshark I can see it's sending a cookie. The content is cryptic, probably like it should be because it only stores a few hashes. I can also see that it connects to an IP address that was not listed by nslookup: 104.124.113.193. IMHO that's ok, because it uses some Akamai load balancing or similar.

4
  • You did everything except, temporarly uninstall ESET, call me cynical I simply don't trust ESET Pausing protection isn't enough in most cases, ESET is notorious, for still doing stuff even while disabled. – Ramhound Sep 6 '16 at 20:39
  • What language packs do you have installed? You have the german keyboard layout installed, but what about language packs, like Google Microsoft will identify what region you are in by your OS language. – Ramhound Sep 6 '16 at 20:40
  • @Ramhound: I'm not exactly sure how to do that. Date formats are German, location is Germany, I have German, English and Chinese keyboards available (German as default). The NIs\Language\InstallLanguage Registry key shows 0409 – Thomas Weller Sep 6 '16 at 20:48
  • You don't know how to check which language packs you have installed? – Ramhound Sep 6 '16 at 21:19
1

I went to the URLs http://live.com to check what information is saved in my profile, but everything seemed ok. From there I followed a link to a linked profile that brought me to my Skype at https://secure.skype.com/portal/profile. The Skype site required me to enter my first name and my last name before I could proceed. Since that time, I am able to go to the Microsoft web sites.

My impression is that my account setup was incomplete which caused an error on Microsoft side. I doubt it's intended behavior, because I would expect Microsoft to prompt for the missing information instead (like it was done on the Skype page).

Perhaps it's relevant to know that while I created a Windows Live account in 2010, I never actually used any of the online features. I can only recall that I signed in to activate a copy of Office 2013 once and I registered for the Windows Insider program. I use the same account for Skype and Visual Studio, but that does not require me to go to a website. Therefore I have never completed the required information before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.