0

I'm copying a folder from local HDD to a remote shared folder. Both systems are Windows 7 SP1, members of the same domain, I am logged in as a domain user and the files are owned by that user. There are a few EFS encrypted files in the copied folder and for them Windows shows a dialog saying:

Dou you want to copy this file without encryption?

You are copying the file to a destination that does not support encryption.

How can I make it just work? That is: copy the files as is (staying encrypted) without dialogs asking questions?

Of course, all involved volumes are NTFS.

Research: I found many questions asking the opposite, but none the same: They copy files (to shred folders) and the encryption remains, they ask how to make it remove the encryption during the copy.

  • You can't. You would have to encrypt the destination directory for it to work. – Ramhound Sep 7 '16 at 12:00
  • You mean encrypt the folder after the copying? – David Balažic Sep 7 '16 at 12:22
  • I found an answer with explanation here: serverfault.com/q/631529/105831 – David Balažic Sep 7 '16 at 13:38
  • You didn't mention you were using Kerberos. You can either enable EFS on the folder before you paste the contents or enable it after words. All you have done is told the second machine to use trust the certificates from other machines on the domain. Be sure you understand the pitfalls of doing that. – Ramhound Sep 7 '16 at 13:49
  • I found that answer, but did not use it (yet). Enabling encryption on a shared folder (on the server side, before the copy) does not help. Now all writes by the remote side fail with an error (Access Denied). – David Balažic Sep 7 '16 at 16:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.