5

I am using multiple wine applications on my Macbook Air running OS X El Capitan. I have tried using both Wineskin and Winebottler in creating wine wrappers for applications that I use and both of them offer the option to enable "fontsmooth=rgb" using Winetricks. However, enabling this option seems to do absolutely nothing. I have also tried enabling fontfix amongst other things to no avail. How can I get Wine to enable font anti aliasing for my apps?

2

It seems to be an issue with FreeType 2.7.0 that's part of XQuartz 2.7.10 and 2.7.11. Try downgrading your XQuartz to version 2.7.9 (https://www.xquartz.org/releases/XQuartz-2.7.9.html).

(Source: https://forum.winehq.org/viewtopic.php?f=9&t=28345)

  • 1
    It worked for me! Thanks. In my case, it happened when I upgraded MacOS from Sierra to High Sierra (10.12 to 10.13). I assume it upgraded XQuartz to 2.7.10/11. I didn't see which I had before downgrading to 2.7.9, but now it works as usual. – DiegoDD Mar 7 '18 at 15:56
2

There is a better solution when downgrading XQuartz is undesirable: to disable new Truetype renderer in FreeType library by exporting FREETYPE_PROPERTIES variable to system:

  1. Open terminal app
  2. Go to home folder cd ~
  3. Run open ‑e .bash_profile or nano .bash_profile
  4. Add following lines:

    export FREETYPE_PROPERTIES="truetype:interpreter-version=35"
    launchctl setenv FREETYPE_PROPERTIES $FREETYPE_PROPERTIES
    
  5. Logout and login

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.