A few days ago, I experimented some strange issues with my Windows Phone device. After lose some data, I decided to perform a hard reset of the device. Previously, I extracted the micro-SD card and copied all its contents to my PC's hard disk. Aparently there was no problem with this copy.

Once loaded on the computer, I tried to erase some folders from the card but it wasn't possible. The card seemed to be readonly protected.

I tried to manipulate the card in a Windows 10 system, in a Windows 7 and in Lubuntu 14.04, using diferent adaptors, USB, standard SD...: in all systems the card was shown as readonly filesystem. Neither Linux's gparted nor Windows' diskpart were able to change this condition.

Despite has been related with a previous question, the difference is that I'm sure is not concerned by a mechanical switch. As I said, I tried to modify this micro SD card in 3 different devices, a PC (dual boot with Linux and Windows10), a laptop (with Windows7) and a Lumia Windows Phone (ver.8.1). To connect the card with the computers I used one SD/MicroSD adapter and two differents USB/MicroSD adapters (with no write protection switch). Both computers displayed messages about a readonly protected filesystem and the smartphone was not capable of install any app or move no multimedia file to the folders in the card.

Any idea of how proceed with this without reformating the card? It is possible the card is fatally damaged or it could be only a problem of corrupted data?

The card is a Lexar 128Gb SDXC, exFAT formatted.


  • 1
    Possible duplicate of Disable write-protection on Micro SD – Ƭᴇcʜιᴇ007 Sep 9 '16 at 15:38
  • 1
    Despite this previous question, I'm almost sure the problem is not related with a mechanical problem. Excuse me if I'm wrong. – T.A. Otero Lojo Sep 10 '16 at 0:45
  • 1
    Read-only is usually triggered if a write operation fails. It's set by the firmware & is not reversible. Bin it. – Tetsujin Sep 11 '16 at 8:31
  • I'm afraid you are right. I tried to format the card, using various tools including the SD Association Formatter and it still appears as write protected. – T.A. Otero Lojo Sep 13 '16 at 14:08

Maybe the lock switcher on your SD card is enabled.

Look at the left side of the card at a grey switcher where it says LOCK ↓. If the switcher is down, your SD card is read-only.

To unlock it, move the switcher up.

  • 2
    I think that micro SD cards have not that physical feature. The SD standard adapter that I used it does have this switch, but I worked with its switch in both positions, and nothing changed. I used an USB adapter too, with no switches, and the results are the same. – T.A. Otero Lojo Sep 9 '16 at 15:06
  • Ok, that's strange because I also have had this problem and the switchers were the problem. – Patrick G. Sep 9 '16 at 15:08
  • Maybe try to open your SD card in Windows explorer, go to the properties of your SD card. Remove the check mark at the point "read-only". Save your changes. – Patrick G. Sep 9 '16 at 15:11
  • I tried that. Not worked. I tried too the diskpart system application and despite it ran without errors, it didn't work. – T.A. Otero Lojo Sep 10 '16 at 0:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.