3

I use Ubuntu 16.04 x64 installed in my Dell i7 machine. I installed Google Chrome Stable Version 53.0.2785.101 (64-bit). It was working fine until I experienced a weird issue yesterday: It just doesn't hold cookies.

I mean, all accounts signed in gets automatically logged out when ever I restart my machine (not browser). If I restart my browser, it just works fine and still logged in. But, when I restart my machine, all accounts like Google, Facebook, etc., gets logged out and I am forced to login again, authenticate 2 step verification, and save the browser (aka trust this browser).

I googled out this issue, and came across "delete cookies and site data once the browser is closed" option, but that's not the case I'm experiencing. My cookies are deleted only when I restart my machine, not my browser.

And, this issue doesn't happen on Firefox and Chromium installed in my Ubuntu.

Ring any bells?

Update: I have tried reinstalling Chrome, deleting data locations (/home/.config/google-chrome, /home/.cache/google-chrome, etc).

1

3 Answers 3

1

For me solution from ask ubuntu helped:

https://askubuntu.com/a/823763/563831

The answer:

Had the same issue. My system is Ubuntu 16.04 and Google Chrome 53.0.2785.101 (64-bit).

Here is my workaround:

  1. Go to Ubuntu System Settings -> Online Accounts
  2. add your Google account there
  3. turned on the switcher (not sure if it is necessary though)
  4. go to Chrome browser and login there again
  5. close the browser window

Note: you must prevent chrome processes from running after closing the window. To do this go to Chrome settings > Advanced settings (at the bottom) > Uncheck 'Continue running background apps when Google Chrome is closed'

Once I did it Chrome stopped dropping authentication after logging out in Ubuntu and also after rebooting

UPDATE: it can happen that after some Ubuntu updates problem returns, however deleting online account and adding it again, solves the problem.

1
  • For me just adding Google account and granting access to Evolution Data Server (Access your Google Calendar) is working workaround :)
    – andrzej1_1
    Sep 16, 2016 at 6:19
1

There is a related-sounding bug report in Chromium:

https://bugs.chromium.org/p/chromium/issues/detail?id=631171

1

Adding one more workaround for this issue:

Go to Passwords & Keys, set a blank password for Default keyring. Restart your system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.