I am having a bit of a problem with my Windows 7 machine and the Hibernate and Sleep options. Last night I ran a full virus scan and, because it said it would be running for a while, told the anti-virus program to shutdown my computer. It did, but when I started it up this morning I saw that my hibernate and sleep option were disabled. I went into Power Options, and saw as well that all my Sleep and Hibernate settings had disappeared. I tried running powercfg -h on in Command Prompt and it came back with this:

Hibernation failed with the following error: The request is not supported.

The following items are preventing hibernation on this system.
        There are one or more legacy drivers installed:

I went to Event Log and check for any errors and found this one regarding GenPort (whatever it is...):

The GenPort service failed to start due to the following error: 
The parameter is incorrect.

Whats going on? Why is my Hibernate and Sleep not working? What is GenPort? How can I rectify this problem?


They are legacy drivers for outputting MIDI sound through your PC speaker (which anyone with a sound card wouldn't need this functionality). If you have these files on your machine, they may prevent your machine from entering hibernate mode.

Genport is usually installed by some old (very old) music related software.

These files are located in your "C:\Windows\System32\drivers" directory and are called genport.sys and genport2.sys. Delete them and the problem will go away.

However, if you really need some legacy music software that needs Genport, then you're better off running them inside a virtual machine otherwise you cannot use hibernate.

This issue affects Windows XP, Windows Vista as well as Windows 7.

There is also a possibility that what is reported as genport by Windows is actually some malware using the driver with the same name or masquerading itself as the old genport driver.

  • @GeneQ, I think you may be right. I have recently installed a music program (not THAT old though). I will try uninstalling it and see what happens... – Kryten Feb 23 '10 at 11:46
  • Hey, you were right! Everything back to normal! Thanks very much! – Kryten Feb 23 '10 at 11:59
  • @Kryten Glad to be of help. :-) – GeneQ Feb 24 '10 at 2:53

Try running the following command from an elevated command prompt (a command prompt running as administrator)

powercfg -energy

This produces an energy report and gives the filename to the report, this might give some indication as to what is causing the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.