0

I have a Dell Precision M6600 laptop with an AMD Radeon HD 8950 graphic card running Windows 10. When I use the graphics driver from AMD, computer games work great, but the brightness control does not work on the computer. When I switch to the Microsoft Basic Display Adapter(see screenshot) computer games are unplayable, but the screen brightness adjusts correctly. I am forced to switch between the drivers depending on what I’m doing.

I’m running Radeon Software Crimson Edition version 16.7.3 and I’ve re-downloaded the driver a couple of times to make sure it’s the latest. If I go to Device manager, Generic PnP Monitor is always enabled.

It’s a pain having to switch drivers every few days. How do I get the brightness to adjust correctly with the AMD driver? Driver Options

Generic PnP Monitor is enabled

2

This issue affects lots of AMD cards and drivers. The fix is as follows.

  1. Go to the registry editor (start > regedit)
  2. Change both of the following registries to 0

KMD_EnableBrightnessInterface2

MD_EnableBrightnesslf2

The registry path can vary slightly, but it will be one of the following or something similar. To find they key, I did a search through the registry.

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class{4d36e968-e325-11ce-bfc1-08002be10318}\0000

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4d36e968-e325-11ce-bfc1-08002be10318}\0001

  1. Reboot.
  2. If it still doesn’t work, in Device Manager, disable your video adapter and re-enable. Make sure your PnP monitor is still enabled.

Note: In my case MD_EnableBrightnesslf2 didn’t exist. In this case just changing KMD_EnableBrightnessInterface2 to 0 will fix the problem.

Registry Fix

  • WHOAH. I have an MSI GX60 (1AE, A10-5750m and 7970m) and I always had a working graphics driver OR adjustable brightness. With linux the fix in grub was easy. But with this solution it works again. THANK YOU :) – ecth Nov 8 '18 at 16:58
  • Works for Lenovo ideapad S405 (I disabled the discrete graphics in the BIOS). Only KMD_EnableBrightnessInterface2 need to be changed to 0. – Jamesits Mar 20 at 3:29
0

For those who have this problem, I found a solution. Follow these steps:

  1. Run Windows in safe mode
  2. Go to Computer Management / Device Manager / Display Adapters / AMD Readon / Driver
  3. Uninstall
  4. Reboot your PC and it will work

PS: It's better to install an old version for good work

  • 2
    DON'T SHOUT! All-caps posts are considered rude and may be quickly deleted. – Donald Duck May 18 '18 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.