6

I have an iMac acting Synergy host, and a MacBook acting Synergy client – both running on OS X.

The native mouse scroll speed is just the way I like it on my iMac, but when I transfer the cursor to the MacBook client, the scrolling speed is just horrendously fast and borderline unusable.

Is it possible to adjust the mouse scoll speed on the client only?


Edit: The iMac host is running OS X El Capitan, and the MacBook is running macOS Sierra, latest versions. Currently using Synergy 1.8.7-stable-c5b83ce.

  • 1
    Can you let me know which version of MacOS you're using? – Josh Harris Feb 21 '17 at 14:36
  • @JoshHarris Sorry for the late reply – I've added it to the question. – Winterflags Feb 24 '17 at 23:02
  • 1
    actually see this answer: superuser.com/a/634449/176770 - i got this same issue sorted with the following command on my client (ubuntu 16.04 machine): killall synergyc; sleep 5; synergyc -f --enable-crypto --yscroll 28 --debug DEBUG 192.168.1.169 – kjones Oct 1 '18 at 3:22
4

Related: How to get mouse-wheel scrolling working with Synergy?

Right now there's no way to tweak the scroll speed in the config GUI, and you have to do it by launching from the command line.

First, we'll need to get the command line string from the GUI, like so...

  1. Open Synergy
  2. Click the File menu (Windows/Linux) or the Synergy menu (Mac)
  3. Click the Preferences menu item
  4. Change Logging level to Debug
  5. Click OK
  6. Click Apply
  7. Click Stop
  8. Scroll up in the log until you see "INFO: command:"
  9. Copy the text after "INFO: command:"
  10. Change the Logging level back to Info

You should have a command line that looks something like this (e.g. on a client)...

/Applications/Synergy.app/Contents/MacOS/synergyc --yscroll 10 -f --no-tray --debug DEBUG --name woody 192.168.1.1 :24800

You can then add the --yscroll 10 argument and play around with the value.

Now, open Command Line (Windows) or Terminal app (Mac/Linux) and paste in the log line and hit the enter key to start. To stop, use the Ctrl+C keystroke.

|improve this answer|||||
  • Thanks for the instructions Nick! I followed them and was successful in starting the client through Terminal. I tried --yscroll 5 and lower settings but doesn't seem to have an effect on the scrolling on the client. The server is running from the GUI. – Winterflags Feb 28 '17 at 12:42
  • Could you try a much higher value like 100? – Nick Bolton Feb 28 '17 at 12:43
  • @Winterflags Any luck tweaking the --yscroll value? – Nick Bolton Mar 3 '17 at 18:04
  • 1
    Sorry for the late reply – it appears to behave identically (as fas as I can tell) with --yscroll 100 as it does with --yscroll 5. Perhaps there is something extraneous, like Logitech Control Centre or something else that is interfering. – Winterflags Mar 4 '17 at 19:51
  • I also experience extremely slow scroll wheel scrolling with a macos server and linux client, and various --yscroll values don't seem to have any effect – kjones Oct 1 '18 at 3:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.