0

We have two PCs running local servers (XAMPP) and we've always been able to view each other's work in the browser via local IP, e.g. http://192.168.1.86/some/website/folder

We changed ISP and with it came a new router (via ethernet, no wireless), and now this link seems to be broken. Both PCs can still access each other's SAMBA, i.e. \\192.168....., but only one of the PCs can access the other via the browser now for some reason. The other now gets the browser error you'd see if a website was down or timed out.

I can't be more specific as I don't know much about this issue or its attendant terminology. I've Googled the issue and run some CMD tests to verify the local IPs (unchanged), and flush DNS caches etc, but beyond this I'm stumped.

Can anyone point me in the right direction?

6
  • Did you check whether the “Network Location” is set to private for both PCs and XAMPP is allowed to accept incoming connections?
    – Daniel B
    Sep 12 '16 at 13:13
  • While I assume XAMPP does, as it always used to. As I say, this only started with a change of ISP/router. Win 10 reports for both PCs under "active networks" that it's a "Public network".
    – Mitya
    Sep 12 '16 at 13:17
  • Don’t assume, check. ;) Because a new router will reset the network location to exactly that: Public network. It’s not what you want for local connectivity.
    – Daniel B
    Sep 12 '16 at 13:24
  • How do I check XAMPP? I opened its CP, but can't see any obvious way to control "incoming connections". I went into Appache's .conf, and can't find the word "incoming" in there. What type of network should I be on for this, then? Thanks for help BTW.
    – Mitya
    Sep 12 '16 at 13:27
  • It’s not in XAMPP but the Windows Firewall you need to check. Simply search the Start menu for “allow firewall”. I’ll write a proper answer later. For that, you also need to provide the Windows version you’re currently using.
    – Daniel B
    Sep 12 '16 at 13:30
1

For an application to be reachable from the network, it must be allowed through the firewall. That terminology is a little backwards, but that’s how Windows calls it.

All reasonably recent versions of Windows maintain three firewall profiles for three types of networks: Public, Domain (not relevant for home users) and Private. This type is also what the Network and Sharing Center displays.

network and sharing center

Windows uses various means to identify a network (as indicated by the network name). The only criterion relevant for home users is the default gateway’s MAC address.

When you switched ISPs, you received a new router. It has a different MAC address. Windows detected this and determined it is on a different network – technically correct.

New/unknown networks are Public by default. This is the most restricted profile and suitable for connecting to public networks like hotspots or your university or whatever.

When Windows asks you whether to allow a program through the firewall, the rule will only apply to the current network location(s) by default. That means you had rules for private networks. They simply did not apply after the router switch.

The best and most appropriate solution is to mark your network connection private again. In Windows 10, the corresponding switch is called “Make this PC discoverable”.

discoverable

It is accessible in the Settings app → Network & Internet → Wi-Fi/Ethernet (depending on connection type) → Click on connected network.

Definitely not recommended, especially on laptops or tablets that frequently connect to foreign networks, is to modify firewall settings for public networks. This will leave your system vulnerable!

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.