35

The "You need to fix your Microsoft account" notification pops up every 10 minutes with the new Anniversary Update. This notification appears because I am not signed into my Microsoft account. I do not wish to sign into my Microsoft account. Ever. Does anyone know how I disable this notification in REGEDIT?

the notification

Note: I know people are having problems with this notification even after they have signed into their Microsoft account. This could be a solution for them as well.

  • 3
    @Don'tRoothereplz... - Nope. Cortana might request it. OneDrive might request it. The reason for that request is understandable, if you want to use either feature, a Microsoft Account is required. I used a local account, on Windows 10 for an entire year and half, which means I did so on every released version of Windows 10 (RTM, Version 1511, and Version 1607). – Ramhound Sep 12 '16 at 17:03
  • 2
    @Don'tRoothereplz... I'm not trying to experience all features completely. I wish to customize Windows as much as I can to do what I need. I do not need my Microsoft account attached to my workstation. What I am looking for is how to use REGEDIT to disable this notification. – LinaleeEshna Sep 12 '16 at 17:46
  • 1
    @Ramhound I'm pretty sure it isn't a bug, but that's not what I'm implying. I'm implying that it is an annoying notification that Microsoft pushes, so that I'm inclined to connect my Microsoft account to my account. I do not with to connect it, ever, so I wish to disable the notification through REGEDIT. – LinaleeEshna Sep 12 '16 at 17:49
  • 1
    @Argonauts I have a traditional product key. I understand that I do not need to have MS account attached my local account. I do not have a MS account attached to my local account. I would like to know how to disable the notification that is pushing me to connect my local account to my MS account. – LinaleeEshna Sep 12 '16 at 18:44
  • 2
    @Argonauts - "If you installed windows 10 using the free upgrade program your license is tied to your MS account." - This is false. This is only true if you, choose to allow this to happen, and only if your using Version 1607. "The former requires that the linked MS account be on the system" - False; I ran my numerous Windows 10 machines without attaching my local profile to a Microsoft Account, and all those installations, were upgraded from the offer. My parents, have machines, both use local accounts. Where are people getting this bad information from exactly? – Ramhound Sep 12 '16 at 21:27
18

First, you'll need a local account. If you already have one, you can go straight to the "Email & app accounts" screen (see further down).

If you don't have a local account, you'll need to create one first (don't worry, this won't reset your settings). Only then can you remove your Microsoft account from your computer, which will get rid of the annoying notification.

Go to Settings -> Accounts.

Accounts

On the "Your info" page, click "Sign in with a local account instead".

Your info

Confirm your current Microsoft account password to continue.

Microsoft sign-in

Choose a username for your local account. You can also specify a password if you want to.

Create local account

You will be signed out of your Microsoft account and can now sign in with the local account you just created. Once you have done this, go back to Settings -> Accounts and go to the "Email & app accounts" page.

Email and app accounts

You should see your Microsoft account listed under "Accounts used by other apps". Click on it, and select the "Remove" option.

Remove Microsoft account

This disassociates your Microsoft account with your PC. You no longer need to enter your Microsoft password to log in and you should also be rid of the annoying notification.

Note: If you need your Microsoft account for any of your apps to work, this solution unfortunately will not work for you.

3

Go to "Settings", then choose "Email & App Accounts" and remove the shown Microsoft account. I already were logging in with a local account, but was still getting notifications with nagging about Microsoft account. Removing the Microsoft account as described above, made the notifications disappear.

0

To get rid of this notification go to PC Settings, Accounts.
Below Manage my Microsoft account you will see Verify your Identity.
Select it and enter your windows account password and press enter.
The notification will no longer display.
The other method above will turn off all notifications.

  • i'm having this problem and have already verified my identity. The item you describe does not appear on my Account page. – cautionbug Jan 7 '17 at 20:33
-2

run gpedit.msc (as administrator)

Under

user configuration
|_  start menu and toolbar
  |_  notifications

Find "turn off toast notifications" and set it to enabled.

  • 4
    Will this turn off all notifications, or just the one related to your Microsoft account? – LinaleeEshna Sep 16 '16 at 19:53
  • And thanks for the answer! I didn't think to use group policy over the registry, but that only makes sense. – LinaleeEshna Sep 16 '16 at 20:08
  • 2
    This is not a solution. It's a silencer. Disabling an OS feature to avoid seeing an ongoing problem isn't solving the problem. – cautionbug Jan 7 '17 at 20:32
  • 1
    It's only a "problem" if you're interested in having a Microsoft account. I use a local user account to log in, I have no interest in having a live account. – Marc Wilson Jan 10 '17 at 2:17
  • 2
    It's a "problem" because it doesn't just disable notifications for a Microsoft account. It disables all notifications for EVERYTHING. – zaTricky Mar 5 '18 at 16:47
-2

Another option if you have notification with work or school account: settings > System > Shared experiences > off

protected by Community Oct 2 at 17:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.