1

Factory install of windows 10.

I Installed IE11 ver 11.545.105.85.0 update ver 110.0.34

I Installed Acrobat Reader ver 2015.017.20053

IE 11 configured to use acrobat reader plugin

When I open a form fillable pdf in 1E11 with acrobar reader it will usually (always?) open correctly the first time. Then when the form is closed (the IE tab is closed) the next attempt to open the form results in a gray screen (usually). If at this point I use task manager and close one of the two entries for acrobat reader the form will open by itself (grey screen goes away and form is visible).

Further attempts may or may not work, if they do not work I see either a gray screen of the error message to the effect that acrobat reader cannot open, if other copies are open close them and retry.

The error has been seen on windows 7 machines, and windows 10 machines that were upgraded from windows 7 as well. All using IE11.

In a span of 15 minutes I was able to reproduce this error on 4 different machines at 3 different locations (customer's office).

There are times (like now when I tried to get the exact error message) that I cannot make it fail...but this morning a customer was having the error, my employee helping him was having the error, and I was able to get the error...

After closing IE11 often the grey screen will appear, a trip to task manager to close acrobat then things will work for an indeterminate period of time.

In case you were wondering: We are required to use IE11 because we use silverlight and we need acrobat reader because we submit the form - currently the only browser to my knowledge that support silverlight and acrobat plugin are IE8-IE11. Firefox will not use acrobat plugin and chrome will not run silverlight.

Any ideas on what might be causing this?

thanks kpg

  • As a followup the solution I went with was to abandon any dependence on the adobe reader plugin and silverlight. Time to move on. – kpg Sep 9 '17 at 3:11
1

I found that the solution put forward on https://www.thewindowsclub.com/pdf-files-will-open-internet-explorer - which involved creating a new registry entry - was not a solution (at first I thought it was). Other successful workarounds were: opening the PDF in Chrome or Firefox, or directly from Adobe Reader.

  • 1
    We prefer that you quote the answer in enough detail to be usable (i.e., your post should stand alone)  and include the link only for reference. – Scott Jul 20 '18 at 18:26
  • That a good practice. I've waited until now to prove or disprove that as a solution since it appeared to work at first, but then the problem would reappear. Now that I have finally tracked down the cause and therefore the solution in our case, I will add another answer. – Tom Benjamin Oct 10 '18 at 0:51
-1

As I mentioned above the registry edit (adding a TabProcGrowth key) was not a solution. There are many posts out there reporting similar issues (PDFs failing to open in IE 11 and hanging the browser), none of the proposed solutions worked for me.

Updating Acrobat Pro and/or Adobe Reader to the latest versions is good practice, and does resolve some issues. The built-in IE Adobe add-on gets updated by doing those updates.

The solution for my issue eluded me until I looked at the network tab in IE's developer tools, and compared it to the behaviour in Firefox. In Firefox the PDF with one single request and response from the web server. But in IE, there were multiple calls, and the really odd thing was that all of the content of the PDF was downloaded in the first response, while each subsequent request was for a few more bytes of the PDF - which don't exist and therefore never completed. That left the browser hanging.

After discovering that, I asked out network analyst to check there was nothing in his realm that was causing this issue. He ruled out the firewall, group policy and IE's trusted sites vs. intranet zone.

I finally realised the problem only existed with PDFs from our corporate website, and those seem PDFs opened without issue if copied to other website platforms (SharePoint and WordPress in my case). As a result, I isolated the problem in my case to the software that our corporate website is built in and runs on: Progress Sitefinity (Telerik). Their technical support says the issue is fixed in version 11, we are running version 10.

The lessons I learned from this were:

  1. Don't give up.
  2. Identify all of the pieces involved in getting a file from a website to a user's PC.
  3. Ask people with expertise that I don't have to help.
  4. Read other suggested solutions thoroughly before trying them out.
  5. Try all the solutions methodically (one at a time), using different PCs, different browsers etc.
  6. If a proposed solution doesn't work, then remove it so you are back to a common baseline.
  • Welcome to Super User. It sounds like you had a similar problem as the OP, however reading your answer it isn't clear how your solution applies to the OP's specific circumstances. Can you edit your answer to clarify how it solves the OP's problem? – I say Reinstate Monica Oct 10 '18 at 1:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.