0

I have an issue with my main user profile - I renamed it, and since then there have been small issues, like the search not finding installed apps, certain Windows apps showing only a blank screen (including Contact Support, which is good for a chuckle), and an occasional hang on restart. I created a test profile, and have confirmed that Search, Apps, and restarting behave as expected with the new profile after initial login.

Once I copy the data from the original user over things get more interesting. The desktop opens quickly, and while some icons lose their program association (links to websites which are represented by Chrome icons on the bad profile), other programs will open on a double click. The issue is that the search box doesn't allow text to be entered, and the start button does nothing. Clicking on File Explorer, I get a message that "Windows cannot access the specified device, path, or file." I tried to screenshot that and save it in mspaint, but on attempting to save I get the message "You can't save to 'This PC'. Please Choose another location." (Dodgy screenshot attached - had to take it with a phone)

errors in new profile

I followed this procedure for copying over the data, which I performed from the built-in Administrator account : https://support.microsoft.com/en-us/help/14039/windows-7-fix-corrupted-user-profile#1TC=windows-7

One exception to the procedure listed was that I found that I had to log in to the new user account before moving files into the folder. If I didn't, even with a default folder specified in the add new user dialog and created by Windows, on initial login to the new user account a folder username.computername would be created in the Users folder. So, I created the user, logged into it once, logged out and back into the built-in administrator account and moved the files from there.

I have a feeling my permissions are off somewhere (maybe everywhere?) in the copied user folders. I have tried to mimic the permissions from another known good account, but no dice. Also, when copying files and presented with a conflict I have been choosing to have the files from the bad profile overwrite the files in the good profile. I did not move NTUSER.DAT, ntuser.dat.log, NTUSER.DAT{string here}, or ntuser.ini files.

How can I set the permissions to get this new profile working? I am considering dropping the whole drive and doing a fresh install from ISO, but the massive number of programs and settings I use for work is keeping me from jumping into that adventure unless truly necessary.

Thanks!

0

I was able to resolve this issue by resetting the Windows file permissions to their defaults. I had tried to reset them a few different ways, but this is what ended up working :

  • If it's not enabled, enable the built-in Administrator Account (at elevated command prompt : net user administrator /active:yes )
  • Log out of all active accounts.
  • Log in as built in Administrator.
  • To restore the default file permissions, at an elevated command prompt run this command: secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose
  • Restart the computer.
  • Log in to the new account - this took longer than usual, I assume due to the settings being applied.
  • Log in to any other active accounts (built-in Administrator will be disabled by the command above)
  • After successful login to all accounts, restart again.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.