My PC with Windows 10 has just received the cumulative update version 1607 (KB3189866).

After the reboot the "net use" command on a network share folder fails with the following error message: "A specified logon session does not exist. it may already have been terminated"

Same problem and error if I tried to insert the path in Run dialog.

enter image description here

Do you know what could be the cause and how to solve it?

  • What have you tried already in attempts to fix it? anther Reboot of your machine? Rebooted the server? If you uninstall the update, does it start working again? Can you connect to the share from any other machines? – Ƭᴇcʜιᴇ007 Sep 15 '16 at 14:46
  • try the WinX menu, open a Command Prompt (Admin..), type net user and hit Enter. – Tony Stewart Sunnyskyguy EE75 Sep 15 '16 at 14:48
  • Connect to share works from other machines. It works also using a Windows 7 virtual machine on the same PC I have installed Windows 10. I tried to reboot a couple of time but I have the same problem. I didn't try to reboot the server, because I cannot perform this operation. – Drake Sep 15 '16 at 14:49
  • Is it a cert issue? – Tony Stewart Sunnyskyguy EE75 Sep 15 '16 at 14:52
  • Have you tried to clear your credentials from credential manager? I have had things get bungled in there after updates. – Unfundednut Sep 16 '16 at 1:36

I found the most conclusive evidence as to the symptom and cause here:

Basically, if an SMB server has any anonymous shares, it appears that the KB3189866 patch causes Windows not does not ask you for credentials and just fails. You can get a number of different error messages for this. In my case it was:

The error you may get is "\\SERVERNAME" is not accessible. You might not have 
permission to use this network resource. Contact the administrator of this server 
to find out if you have access permissions. A specified logon session does not 
exist. It may already have been terminated

There are two workarounds, either:

  1. Uninstall KB3189866 (useful for proving it is the cause)


  1. Add credentials for that share into the Windows Credential Manager:

    a. Go to Control Panel -> User Accounts -> Manage Your Credentials -> Windows Credentials

    b. For each server you wish to access, add in an entry (using "Add a Windows credential") with:

    • Internet or network address: \\SERVERNAME
    • User name: guest
    • Password: guest
  • Thanks. Had the issue with my D-Link DNS-323. Thought it might have crashed but was available from other machines. Added \\SERVERNAME and guest/guest. Voila worked. – Wolf5 Nov 24 '16 at 16:39

I had this issue too.

The issue only happened when I was using an MS account, and not a local account.

To get round the issue I found I could not just browse to my NAS, I now had to map a drive and tick the "use alternate credentials" box.

When I forced the use of hostname\accountname I found I could get back into my files. This should be better than sending a clear text password, but I think MS need to fix this. I put a longer response on the MS community page after someone else logged the issue.



I found a sort of workaround, not a real solution, but I post it here because it may be helpful for someone. By the way, a colleague received the same update and had exactly the same problem on a different machine.

It seems like there is a problem with prompt of credentials because if I write the full "net use" statement and specify also the password it works.

For example:

net use I: \\network_name\share /USER:domain\username password

If I remove the password it throws the error instead.

  • To be fair, if the user has a password, it makes sense that command fails without a password – Ramhound Sep 16 '16 at 12:39
  • Before the update it prompts for password if you executed the command in command line without specifying the password – Drake Sep 16 '16 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.