6

After removing tmux resurrect and cleaning the whole folder ~/.tmux/ while starting tmux in bash (MacOsX El Captain) I am getting infromation:

"Restored session: Thu Sep 15 17:15:04 CEST 2016"

I am assuming that I have not removed entirely tmux ressurrect or tmuxinator but I can't figure out a way to disable it.

EDIT:

  1. find / tmux - no files or directories found
  2. find / resurrect - no files or directories found
  3. after uninstalling and reinstalling again tmux (using brew) still didn't help

EDIT2: output of command cat tmux-server-4144.log | grep session

1473953899.570430 cmdq 0x7fe92ae04d10: bind-key $ command-prompt -I#S "rename-session '%%'"
1473953899.570436 preparing state for bind-key $ command-prompt -I#S "rename-session '%%'" (client 0x0)
1473953899.573639 cmdq 0x7fe92ae09cd0: new-session
1473953899.573643 preparing state for new-session (client 0x7fe92c003000)
1473953899.573646 cmd_find_current_session: have client 0x7fe92c003000
1473953899.573661 cmd_find_current_session: have client 0x7fe92c003000
1473953899.574922 new session 0 $0
1473953899.574926 session 0 activity 1473953899.574925 (last 0.000000)
1473953899.575243 session 0 created
1473953899.575270 session 0 activity 1473953899.575268 (last 1473953899.574925)
1473953899.575291 session 0 has 3 references
1473953899.575295 session 0 has 2 references
1473953899.587201 input_parse: %0 ground, 49 bytes: Restored session: Thu Sep 15 17:35:52 CEST 2016\r\n
1473953902.034714 session 0 activity 1473953902.034710 (last 1473953899.575268)
1473953902.034724 session 0 not pasting
1473953902.201937 session 0 activity 1473953902.201934 (last 1473953902.034710)
1473953902.201943 session 0 not pasting
1473953902.306065 session 0 activity 1473953902.306061 (last 1473953902.201934)
1473953902.306073 session 0 not pasting
1473953902.402305 session 0 activity 1473953902.402301 (last 1473953902.306061)
1473953902.402313 session 0 not pasting
1473953902.834269 session 0 activity 1473953902.834265 (last 1473953902.402301)
1473953902.834277 session 0 not pasting
1473953902.834674 input_parse: %0 ground, 17 bytes: Saving session...
1473953902.856287 session 0 has 2 references
1473953902.856292 session 0 destroyed
1473953902.856295 session 0 has 2 references
1473953902.856298 session 0 has 1 references
1473953902.856334 session 0 freed (0 references)

5

El Capitan's terminal session should only run under new Apple Terminal windows, but affects all interactive bash sessions regardless of terminal. Oops.

Run touch ~/.bash_sessions_disable to disable it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.