So I installed new linux distro recently (pinguyOS) and now I am trying to install flash plugin for Opera browser: sudo apt-get install flashplugin-installer.

The output of dpkg --status flashplugin-installer is:

The Adobe Flash Player plugin will work with a range of web-browsers including, limited to:
* Firefox
* Chromium
* SeaMonkey
* Iceweasel
* Iceape
* Galeon
* Epiphany
* Konqueror

Since Opera isn't listed I followed official instructions for installing Opera Adobe Flash Plugin:


I copied libflashplayer.so from its original directory to /usr/lib/i386-linux-gnu/opera/lib. Flash player is still unable to load and when I check browser for installed plugins opera://plugins it says Flash Player is enabled but there is this weird version of the plugin:


I use Opera v 39.0 and the official opera documentation is outdated (v11.0) but I even tried to install PPAPI version of flash plugin and replace libflashplayer.so with libpepflashplayer.so but plugin is still not working. It shows still the same error: Flash plugin failed to load.

Can you help me find out where the problem is please?

2 Answers 2


I was having the same problem, until I found the doc on their official page. Basically you have to do the following:

  • locate libflashplayer.so, or
  • find / -name libflashplayer.so 2> /dev/null

If Adobe Flash Player is not installed, or you wish to upgrade, proceed as follows:

  • Download the plug-in from Adobe's website. The plug-in is available in various formats, including .deb, .rpm, and .tar.
  • Follow the instructions on the download page.

    • If you choose the .tar file, you need to unpack it tar xvf install_flash_player_10_linux.tar.gz
    • copy libflashplayer.so to /usr/lib/opera/plugins
    • A user without root access can copy the the plug-in to $HOME/.local/lib/opera/plugins.
  • Restart Opera.

  • Verify that the plug-in is working by going to Adobe's test page.

I can fix it first step for step and try if your browser show the video multimedia:

1º update or install chronium ffmpeg codec

sudo apt install chromium-codecs-ffmpeg-extra

2º if the bug persist:

try it: sudo apt install adobe-flashplugin

3º try installing this global codec for linux

here install ffmpeg version 4.x for linux


remember, every step when you change in your system try to play

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.