2

I have a problem with my microphone volume. When I bought my headset I set the volume to 100%. But from time to time the volume goes down to about 92%. That does not sound much but my friends told me that they can barely understand me with 92%.

I am using TeamSpeak3 and I found an option there which I disabled.

Options -> capture -> advanced options -> automatic voice gain control

I disabled that check box but the problem is still there.

I also noticed that windows itself seems to adjust the microphone volume: When I scream into the microphone the volume goes down to 50% and goes up again to about 92%. The going down makes sense to me but why wouldn't it go all the way up to 100% again? This happens when TeamSpeak3 is open as well as when TeamSpeak3 is closed.

So my question is: How can I lock the microphone volume to stay at 100%? Or how can I make sure that it goes up to 100% again after loud noise?

Here is a screen shot of the microphone where I have to adjust the volume to 100% all the time.

enter image description here

I also disabled the exclusive control in the advanced tab as described here

  • If you are not using Skype, you don't need to mention that solutions geared toward Skype, are not appliciable to your situation. That is a given, I suggest, reporting any comment or answer that even mentions Skype as not being constructive. – Ramhound Sep 16 '16 at 19:54
2

I know this is old but it still gets top search rank. you can lock the volume completely, other programs keep setting the microphone volume to 100%. you have to use nircmd to lock it.

if not "%minimized%"=="" goto :minimized
set minimized=true
start /min cmd /C "%~dpnx0"
goto :EOF
:minimized
cd /Windows/System32/
nircmdc.exe loop 172800 100 setsysvolume 57016 default_record

You can put this in a '.bat' file and put it in the startup folder.

| improve this answer | |
  • The answer by shayan is actually a good one, but it needs to be noted that it relies on the third party software NirCmd. That needs to be present on the system and placed in the appropriate directory for the solution to work. – drseussofporn Mar 8 '19 at 19:25
  • The full volume is 65535; so if you want 87%, you multiply it by 87/100. Reference: techticity.com/howto/… – Korayem May 16 '19 at 0:14
0

Self answer here:

All the programs i have either don't use the microphone or offer a configuration value that lets me disable the microphone adjusting.

All but TeamViewer. Even if i'm not using it actively while sitting in the tray it will adjust the microphone volume. At the time of writing there is no option to disable that behaviour.

At least it is reproducible and i can now manually fix the volume after closing TeamViewer.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.