I have an HP K3510 Wireless Keyboard and it does not appear to have a Num Lock key on it even though it has a number pad area with the numeric characters?

enter image description here

| |
  • Numlock is used to differentiate dual meanings of the number pad keys. On your keyboard, those are dedicated keys. There's no need for num lock. – fixer1234 Sep 17 '16 at 6:42
  • 3
    @fixer1234: I'm not sure that's true.  On my (Dell) keyboard, the numeric pad keys look like the ones in the OP's picture — they have nothing printed on them except for the numerals "0" through "9".  But, if I press and hold "Shift", or press and release "Num Lock", my numeric pad keys become Home, End, PgUp, PgDn, and cursor (direction) keys — even though I have eight other keys dedicated to those functions. – Scott Sep 17 '16 at 19:45
  • @Scott, the question was why the num lock key was missing on that keyboard. The fact that those, apparently dedicated, keys can be switched to a secondary meaning could be a non-obvious feature or vestigial function. Since there are dedicated keys for both of the number pad functions, HP could have figured that num lock was a dispensable key when figuring out how to fit all the keys on the available real estate. – fixer1234 Sep 19 '16 at 3:46
  • 1
    probably the only way is autohotkey – phuclv Oct 6 '17 at 5:46

It’s not clear exactly what your question is, or what you have tried.  For example, what happens if you type on your numeric keypad while holding down the Shift key?  Do they act like Home, End, PgUp, PgDn, and cursor (direction) keys then?

If your numeric keypad keys are dual-function, and you want to use the navigation functions of those keys without holding down Shift, or if you find them generating the navigation key keycodes by default (and you want to switch it back to normal), and you’re running Windows, try this advice offered by HP:

  1. Run the On-Screen Keyboard program.  There are several ways you can do this:

    • Click on “Start”, type “on-screen”, and when “On-Screen Keyboard” appears, click on it.
    • Click on “Start” and navigate to “On-Screen Keyboard” (on my Windows 7 machine, it is under “All Programs” → “Accessories” → “Ease of Use”), and click on it.
    • Click on “Start”, click on “Run…” (if you have it on your Start Menu), and type “osk” (and press Enter).
    • Press (Windows)+R, and type “osk” (and press Enter).
    • etc.
  2. Then,

    • If your On-Screen Keyboard has a “Num Lock” on-screen key, click on it.
    • Otherwise, or if that doesn’t work, click on “Options”, “Turn on numeric keypad”, “OK”, and then try again.
| |

As you see on the numpad keys, there are no alternative function for each key, such as Home or arrow keys. This is no problem as you already have dedicated keys for that.

On my own laptop keyboard, I have both but for some reason they chose to remove it from yours, which in my personal opinion looks more elegant. Nobody ever uses the alternative functions of the numpad anyway.

| |

I bought same keyboard and have been looking for a solution for a while but there is non.

For the guys who doesn't understand what the problem is, the people who wants compact keyboard usually expects the number key pad does dual functionality with 'NumLock' toggle key.

Also, pressing shift key to activate the dual function doesn't help that much because it's not possible to enter combination of keys that text editor or office programs supports like 'control-shift-home'.

The 'dedicated function key' on the keyboard is not on standard location and users who use more than 2 keyboard will get confused very easily. So, this keyboard layout is useless if there is no 'Num Lock' key.

Anyway, who does need dedicated 'Paste' key instead of pressing Ctrl-V ? I guess the HP keyboard designer does a lot of 'paste' instead of typing something useful.

| |

Not the answer you're looking for? Browse other questions tagged or ask your own question.