44

I recently updated to Windows 10 anniversary update and recentlly noticed the PS/2 Keyboard has stopped working in Windows 10 apps such as the settings menu and the start menu. Desktop apps and control panel work fine including shortcuts buttons such as volume up, web browser etc.

The default driver installed seems to be Lenovo ThinkPad driver PS/2 keyboard (which the keyboard Is not). I uninstalled the driver, un-plugged keyboard and tried changing the driver to the standard driver and HID keyboard driver with no luck.

How can I get the keyboard to work in the Windows 10 app section?

8
  • This sounds like a hardware failure. My PS/2 keyboard has no problems on my system
    – Ramhound
    Sep 17, 2016 at 12:49
  • 1
    The chances of it being a driver problem, is very unlikely, PS/2 driver hasn't changed in years. Have you tried a different keyboard?
    – Ramhound
    Sep 17, 2016 at 20:28
  • 1
    @Ramhound - I was having the same issue, the keyboard works fine in other apps, but just not for the start menu or built-in windows 10 apps like the calculator.
    – Tasgall
    Jan 24, 2018 at 9:26
  • 1
    @Tasgall If the keyboard works then it literally cannot be a driver problem
    – Ramhound
    Jan 24, 2018 at 12:13
  • 1
    @Ramhound - it also means it can't be a keyboard hardware problem. The answer to run ctfmon.exe fixed the issue for me, so it looks like an OS issue.
    – Tasgall
    Feb 25, 2018 at 15:15

5 Answers 5

74

If you are still stuck try this simplest of the solution.

  1. Press Win+R (to open Run )
  2. Copy paste and press Enter to run this program. C:\Windows\system32\ctfmon.exe. It brings back the language bar and for me it allowed me to type in Windows search, start menu and Windows 10 apps again.

I think it is due to the missing language bar or something like that.

6
  • 5
    Wow, this worked for me. Now start menu reacts to keyboard again!. Thank you very much! Jul 16, 2017 at 23:02
  • 4
    Is there a (preferred) way to ensure that ctfmon.exe runs on system startup? I can run it and the problem goes away but only until I reboot. Nov 19, 2017 at 5:52
  • 2
    This is - at least for me - only a temporary fix which works until the next reboot
    – dufte
    Apr 26, 2019 at 7:26
  • In my case the CTF Loader was called by the Touch Keyboard and Handwriting Panel Service (TabletInputService), which was disabled because I am not using a tablet. Setting that to manual and then re-enabling Microsoft/Windows/TextServicesFramework/MsCtfMonitor in the Task Scheduler Library did the trick. If that does not work, try setting it to automatic. But I think manual (triggered) is the way it is supposed to work.
    – Tharkon
    Jul 25, 2019 at 23:36
  • 1
    @Daniel Williams 2020 here, still facing the issue, guess they are focusing more on pushing bloatware using windows updates rather than working on actual issues.
    – Harshiv
    Feb 10, 2020 at 16:05
49

I had the same problem. This is what worked for me:

  1. Open Task manager.

  2. Find Cortana (or SearchUI/Search) on the Processes tab

  3. Right click it - End task

13
  • 2
    "SearchUI.exe" on the details tab in task manager
    – StingyJack
    Jul 9, 2017 at 21:04
  • 1
    This is - at least for me - only a temporary fix which works until the next reboot
    – dufte
    Apr 26, 2019 at 7:29
  • 1
    I killed "CTF Loader" process and start working again Mar 11, 2020 at 7:42
  • 1
    so combining this with zas's answer worked for me Oct 29, 2020 at 6:38
  • 1
    I tried Cortana but it didnt work. It worked with Search (not SearchUI). It works because Search restarts after you end it as a task (might add this info at the answer)
    – kkica
    Nov 21, 2020 at 2:22
11

I solved the problem by ending the "search" process in task manager. (I have cortana disabled)

1
  • This was my problem as well. cftmon.exe and killing cortana did not work.
    – tif
    Feb 19, 2021 at 9:32
4

Found this solution that worked for me:

http://www.tenforums.com/drivers-hardware/64757-keyboard-does-not-work-windows-store-apps.html

(Win+R > taskschd.msc > Task Scheduler Library > Microsoft > Windows > TextServicesFramework. Right click MsCtfMonitor and choose Enable. Reboot your PC.)

1
  • 1
    You can just right click Run after clicking Enable as well. Also make sure that the Touch Keyboard and Handwriting Panel Service (TabletInputService) is available.
    – Tharkon
    Jul 25, 2019 at 23:37
0

None of the answers worked for me, so I simply opened Task Manager, killed explorer.exe (Task Manager - Details - locate explorer.exe and kill it) and run it again (Task Manager - File - Run new task - type "explorer").

Not the answer you're looking for? Browse other questions tagged or ask your own question.