27

I recently updated to Windows 10 anniversary update and recentlly notiecd the PS/2 Keyboard has stopped working in Windows 10 apps such as the settings menu and the start menu. Desktop apps and control panel work fine including shortcuts buttons such as volume up, web browser etc.

The default driver installed seems to be Lenovo ThinkPad driver PS/2 keyboard (which the keyboard Is not). I uninstalled the driver, un-plugged keyboard and tried changing the driver to the standard driver and HID keyboard driver with no luck.

How can I get the keyboard to work in the Windows 10 app section?

Thank You

  • This sounds like a hardware failure. My PS/2 keyboard has no problems on my system – Ramhound Sep 17 '16 at 12:49
  • @Ramhound Possibly but I don’t understand why it works for the desktop section. I thought it could be a driver or security issue between the keyboard and Win 10 Metro Section. – TheIdiot Sep 17 '16 at 12:54
  • 1
    The chances of it being a driver problem, is very unlikely, PS/2 driver hasn't changed in years. Have you tried a different keyboard? – Ramhound Sep 17 '16 at 20:28
  • @Ramhound - I was having the same issue, the keyboard works fine in other apps, but just not for the start menu or built-in windows 10 apps like the calculator. – Tasgall Jan 24 '18 at 9:26
  • @Tasgall If the keyboard works then it literally cannot be a driver problem – Ramhound Jan 24 '18 at 12:13
56

If you are still stuck try this simplest of the solution.

  1. Press Win + R (to open Run )
  2. copy paste and press enter to run this program. "C:\Windows\system32\ctfmon.exe". it brings back the language bar and for me it allowed me to type in windows search, start menu and WINDOWS 10 apps again

I think it is due to missing Language bar or some think like that

  • 3
    Wow, this worked for me. Now start menu reacts to keyboard again!. Thank you very much! – Jakob Sternberg Jul 16 '17 at 23:02
  • 2
    This is crazy, it worked – hardkoded Oct 13 '17 at 12:31
  • 3
    Is there a (preferred) way to ensure that ctfmon.exe runs on system startup? I can run it and the problem goes away but only until I reboot. – Craig Silver Nov 19 '17 at 5:52
  • 1
    This is - at least for me - only a temporary fix which works until the next reboot – dufte Apr 26 at 7:26
  • In my case the CTF Loader was called by the Touch Keyboard and Handwriting Panel Service (TabletInputService), which was disabled because I am not using a tablet. Setting that to manual and then re-enabling Microsoft/Windows/TextServicesFramework/MsCtfMonitor in the Task Scheduler Library did the trick. If that does not work, try setting it to automatic. But I think manual (triggered) is the way it is supposed to work. – Tharkon Jul 25 at 23:36
29

I had the same problem. This is what worked for me:

  1. Open Task manager.

  2. Find Cortana or SearchUI on the Processes tab

  3. Right click it - End task

  • The funniest thing is, this is the worst rated answer on this post but it did solve my problem. – Sebastien Apr 18 '17 at 13:56
  • Seems like Cortana is having a bit o'fun with my keyboard. – Sebastien Apr 18 '17 at 13:57
  • This just worked for me as well - zas' answer had no effect. – verism Jul 5 '17 at 9:15
  • 2
    "SearchUI.exe" on the details tab in task manager – StingyJack Jul 9 '17 at 21:04
  • 1
    This is - at least for me - only a temporary fix which works until the next reboot – dufte Apr 26 at 7:29
5

I solved the problem by ending the "search" process in task manager. (I have cortana disabled)

3

Found this solution that worked for me:

http://www.tenforums.com/drivers-hardware/64757-keyboard-does-not-work-windows-store-apps.html

(Win+R > taskschd.msc > Task Scheduler Library > Microsoft > Windows > TextServicesFramework. Right click MsCtfMonitor and choose Enable. Reboot your PC.)

  • This answer helped me! – BestR Sep 1 '17 at 7:31
  • You can just right click Run after clicking Enable as well. Also make sure that the Touch Keyboard and Handwriting Panel Service (TabletInputService) is available. – Tharkon Jul 25 at 23:37

protected by Community Dec 15 '17 at 20:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.