0

I could not find any help with this anywhere so I thought I would ask a question here.

I have two VirtualBox VM's, one Fedora 23, and one Windows 7. I'm trying to get them to communicate over VirtualBox using virtual networking (I hope that's the right term).

I've tried many options for the adapters. Yet if I try anything other than NAT Fedora doesn't get a connection. In fact a message appears on the screen saying "Activation of network connection failed". Pings to the gateway or the other VM return the message "Network unreachable".

Obviously something is causing the VM's to be unable to connect.

The Windows 7 VM doesn't show an active connection either.

I was a little hasty in setting up the virtual connections so I'm not sure what I've done. I do know that I created another Ethernet Host Only Adapter under File->Preferences->Networking in the VB main application, then deleted it with the VM's still operating.

I think that may be the problem but nothing I've tried has remedied it.

2
  • How would you like your network setup? Should the guest VMs be able to communicate with each other? (I'm assuming yes on this one) Should the VMs be able to communicate with host machine? Should the VMs be able to communicate with the Internet/host machines network?
    – heavyd
    Commented Sep 17, 2016 at 22:00
  • I just want the VMs to connect to each other. No connections to the internet, but definitely with the Host machine.
    – jayftw
    Commented Sep 17, 2016 at 22:32

1 Answer 1

2

Based on your comments it sounds like you want to use the "Host Only" networking mode in Virtual Box. This will give you communication VM to VM and VM to host.

To configure this mode open the Virtual Box Preferences dialog to the "Network" tab. (File -> Preferences). Then select the "Host Only" tab in the preferences pane. Make sure you have at least one entry in the list, if not add a new one. You'll want to edit the configuration to make sure that the DHCP server is enabled. Once that is set you should just have to configure the Network adapter on each VM so that is attached to the "Host Only" adapter and the Name of the Host Only adapter you configured is selected.

1
  • Thank you for your help! I tried that but wasn't sure about the proper way to go about it. I think I had configured the virtualbox ethernet only adapter settings and DHCP server settings wrongly. It is working now.
    – jayftw
    Commented Sep 18, 2016 at 10:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .