0

My computer has 2x2GB RAM right now and this works fine. I got one stick (from another computer) that is 8GB and I want to put it into my computer. All memory is DDR3.

However, the computer does not boot at all if I have a single stick in any of the channels - it just sits there with a black screen and doesn't even go to BIOS, so I have no idea what it's upset about.

I have tried:

  • Putting 8GB into slot 1 (out of 1-4), no other RAM. Same problem. I've tried it alone in all four slots.
  • Putting 2x2GB into slots 1+3, 8GB into slot 2, same problem
  • Putting 8GB into slot 1, 2x2GB into 2+4, same problem
  • Putting 1x2GB into slot 1, no other RAM. Same issue.
  • Increasing the DRAM voltage slightly (to 1.51), same problem.
  • Changed the DRAM timing to match the new stick, same problem.

So I don't think it has to do with the RAM stick itself, but rather the motherboard or the processor I guess. I was under the impression that all motherboards would support a single RAM stick regardless, but apparently that isn't the case?

My hardware:

  • CPU: AMD FX-8320E
  • Motherboard: MSI 970
  • RAM 2x2GB: Corsair CMX4GX3M2A1600C9
  • RAM 8GB: Corsair CMV8GX3M1A1600C11

My BIOS is up to date (M40). What could be going on?

Edit: I think it's the RAM stick. I got my computer to boot with 1 or 2 of the 2GB sticks that I currently use after resetting the BIOS. But I cannot get this new one to do anything. Oh well, guess it's back to the store tomorrow!

  • While it might be the RAM stick itself, are you familiar with dual channel memory? Some motherboards won't boot if the memory isn't configured to be in dual channel (i.e. same RAM types/speed/size in the conjoining slots) .. and that motherboard is a dual-channel board (at least from the specs I could find) .. – txtechhelp Sep 18 '16 at 3:52
  • @txtechhelp, it turns out it can boot fine (as per my edit) with a single stick of old ram. So I don't think it's the motherboard being "dual-channel". I am familiar with dual channel memory though. – Catsunami Sep 18 '16 at 3:55
  • Could be a tiny short or blown IC on the stick that causes the system to not respond (e.g. no boot because the RAM doesn't "complete the circuit" so-to-speak) .. It's always a bummer when a module goes out :/ – txtechhelp Sep 19 '16 at 4:17
  • @txtechhelp, yeah, I got the RAM stick replaced (yesterday) and the new one worked right away. I think it was just a faulty stick. Thanks for your help though. – Catsunami Sep 19 '16 at 16:10
0

MSI 970 supports maximum 32 GB ( 4 x 8 GB) DDR3 1066/1333/1600/1866

Since the 8 GB module is not recognizing by the Motherboard, the memory could be at fault.

Refer specifications here: https://www.msi.com/Motherboard/970-GAMING.html#hero-specification

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.