0

I have a shared folder on my Windows 10 Pro (1607) PC that is accessed by a Windows 10 Family (1607) PC. This setup stopped working overnight (a couple of months back), probably because of an update.

Now I am struggling to make it work again. I feel like I've tried everything:

  • With and without Homegroup
  • Changed workgroup
  • With and without credentials
  • Changing the owner of the drive / folder to be shared

Both PCs have the same Admin User that is logged in automatically (via netplwiz). I've gotten to a point where I can see the shares, but not access them.

To test, I created a new share on my desktop, and this one works (!). I tried to find out the differences between the two folders. See the screenshots, the left one is working (Canon) whereas the right one (K) is not working:

Share Share

The only difference I could find was that on the left, the checkboxes are greyed out. Why ?What else can I do ?

This is driving me insane...

13
  • What do your event logs say when access gets denied?
    – qasdfdsaq
    Sep 18, 2016 at 14:31
  • Where would I see that ? I did not find anything
    – Tim
    Sep 18, 2016 at 15:34
  • Click start, type event logs
    – qasdfdsaq
    Sep 18, 2016 at 15:35
  • Could not find any reference to this error. I cleared the lists and reproduced it, but nothing new appeared
    – Tim
    Sep 18, 2016 at 19:02
  • If your event logs show nothing at all then your client isn't even connecting to the machine at all and cannot be getting an "Access denied" error, more likely "Unreachable" or "Time out"
    – qasdfdsaq
    Sep 18, 2016 at 23:38

1 Answer 1

-1

For shared folders to work on Windows 10, these steps may help:

a) In Network and sharing center file sharing (network discovery) must be enabled. Turn off password-protected sharing: first make it work simply, then make it work with password protection if necessary.

b) In "Turn Windows features on and off" window (from Run: appwiz.cpl), under "SMB 1.0/CIFS File sharing support", SMB client and server must be enabled.

c) When sharing a folder or a drive, in the properties window on both "Sharing" and "Security" tabs, make sure privileges are given to "All" (other unnecessary entries can be removed). Again, first make it work, then make it work with security.

d) Also, certain services must be enabled but they typically are (you can find which ones in Google). Some suggest than in Network and sharing center network type should be Private and if it can't be changed there, it's possible to set it through a PowerShell command (details can be found on answers.microsoft.com).

Hope this helps.

1
  • 1
    Any sane user should never enable SMB 1.0 on any machine accessible to the intranet. It's insecure, and while the most severe vulnerability was patched, it's not secure and should never be used.
    – Ramhound
    Nov 2, 2020 at 18:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .