6

For some reason, Windows Explorer has started cutting off everything after a dot (.) in my folder names.

Example:

alt text

Any ideas? I do have TortoiseSVN installed, which provides the icon overlays, but that's never been an issue before.

Also, I'm using Windows 7 64-bit and Hide Extensions for know filetypes is not checked.

3

Looks like the 'feature' to hide extensions. Check in the Folder-Options (you can find it in the Control Panel, and then the tabpage View) for it.

Edit: Oh, in that case sorry, this is the only discussion which I found whcih comes close to your problem.

2
  • This is -supposed- to just be for files, but it's the first thing that I thought of too. If it IS infact a solution, there must still be a deeper problem. – Phoshi Feb 23 '10 at 20:56
  • That's the first thing I checked. Hide extensions for known file types is unchecked. – jerhinesmith Feb 23 '10 at 21:04
3

OK, so following the link that Bobby posted, I found the solution. I had originally changed the default folder that the Windows Explorer taskbar icon opened to. So, instead of opening to:

%windir%\explorer.exe

I modified it to open directly into my C Drive:

%windir%\explorer.exe /n, /e, /select, C:\

After noticing that the folders were correctly named if I opened Computer from the start menu and navigated to the same directories, I changed the shortcut back to the original string and that seems to have fixed the problem.

1
  • I have the same problem, but I have not changed the link of my taskbar icon. I do have TortoiseSVN installed. – gpvos Jan 10 '13 at 13:19
2

I found a solution posted by Lee Diggins at Microsoft Community that fixes the problem. It is a Fix it tool from Microsoft.

One thing to note is that if you have some customisations you wish to remain, for example customs icon for files/folder, be sure to choose the option of Detect problems and let me choose the fixes to apply instead so that you can choose which fixes are desired.

For me I only chose the fix for View and Customisation problem for a folder.

0

This corrected the problem for me.

I had changed the explorer target to open on My Computer with following argument:

%windir%\explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}

Restoring the target to %windir%\explorer.exe corrects the problem, without having to restart windows. And after having launched Explorer at least once, I can reset the target to the modified path.

0

For myself, I saw this when starting Explorer from the link pinned to my task bar. If I opened Explorer from the start menu or the "This PC" link on my desktop it worked fine.

I fixed the problem by unpinning Explorer from the task bar, opening a new Explorer window, navigating to my desired folder, and pinning again.

I don't know what originally triggered the problem (it had previously been okay) so I don't know if this solution will be permanent. The problem may have been related to Tortoise SVN (as the original question suggested), as I recently installed that, but none of the solutions offered here fixed the problem for me.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.