1

My network is managed by the TP-Link TL-WR840N router and provides both LAN and WLAN channels.

I have my laptop with local static IP 192.168.0.113 which is connected via WLAN. On the laptop runs a Tomcat 8 under 8088 port. If I connect to it from a Raspberry PI, which is connected via LAN, everything works just fine.

Although if I try to connect to the very same laptop from other devices over WLAN, I get ERR_ADDRESS_UNREACHABLE in Chrome or EHOSTUNREACH (No route to host) in Android.

What am I doing wrong? What should I check in the first place?

1

Sounds like you might have wireless isolation mode on (which stops wifi clients talking directly to each other).

It's accessed in the menu's of the router under

  • Wireless
    • Wireless Advanced
      • Enable AP Isolation
|improve this answer|||||
  • 1
    Strange thing... Originally the Enable AP Isolation was unchecked, and wireless clients couldn't see each other. Then I checked it (no effect), and unchecked it again. And then it worked! So, I assume, that original value was true, and it was not properly displayed in the UI – injecteer Sep 20 '16 at 9:17
0

point the addresses to a valid dedicated IP that will route correctly rather than object.

Check advanced settings for Wireless.

|improve this answer|||||
  • 2
    A bit more explanation would be good ... as it stands it doesn't really answer the question. "What am I doing wrong? What should I check in the first place?" – DavidPostill Sep 19 '16 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.