Server is Windows 10 Pro. version 1511 build 10586.589 Client is Windows 10 Home. version 1607 build 14393.187

The first time server boots up and I connect, everything runs smooth.

When I disconnect the server seems to be pertaining changes made by client such as resolution, removed wallpaper and numlock status.

After that, I am unable to connect until I reboot the server. I get the black screen on connect for a while then it fails.

Another thing I noticed is that on initial connect which works, I get loading message "Other User" with Server's background color, but after that I get the same loading message with broken loader (not animated) and client's background color.

I'm using remote desktop to connect to my pc from laptop, hence the user is always signed in.

I force my connection to use slowest setting (modem) to optimize speed.

When I work on server directly and leave, I lock the screen with win+L and when I work remotely I disconnect with either X on the bar or win->power->disconnect (which seems to yield same result).

  • From the Remote Desktop Connection screen before you connect to the server via RDP go to the Local Resources tab Local devices and resources and UNcheck the Printers option, and then connect and see if your issue still occurs. Test the Experience tab Persistent bitmap caching setting being off, and then connecting. For the "Speed" setting pick LAN for highest setting as well. – Pimp Juice IT Sep 19 '16 at 22:04
  • I've tried each and all of those fixes and they do not help much. Sometimes it works (mostly if i reconnect within minutes) and most times it does as in question. My current workaround is using teamviewer to restart computer if not working..... – mtbnunu Sep 20 '16 at 0:23
  • if you run winver+enter what are the version and OS build numbers you see for both client and server? You are RDP'ing into a Windows 10 "Home" edition as the server? – Pimp Juice IT Sep 20 '16 at 1:09
  • Sorry, the server is Pro. version 1511 build 10586.589 and client is Home. ver 1607 build 14393.187 – mtbnunu Sep 20 '16 at 7:33
  • Not exactly sure but it seems like having visual studio open increases the likelihood of this problem. Without it open, problem still exists but frequency is noticeably lower. – mtbnunu Sep 20 '16 at 7:40

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.