0

I'm having problems verifying a pgp/gpg signature file. I am using GnupG through GPG Suite for Mac OS X. Normally I can verify signatures fine, but lately I am getting an error:

Verification failed: No signature found

when I receive a signature .asc file and click on the file. I am positive I have the senders public key in my keyring. And just recently I realized I am having trouble verifying a text signature also, I tried to verify the signature from gpg tools and the signature associated with the tor browser bundle and keep getting the same message. It's very annoying. If anyone is having similar issues or can think of something I can do please let me know.

  • Have you confirmed that the sender actually signed the file? I've had this issue before and it was determined that the sender was not signing the file even thought they encrypted it so I figured I'd ask the obvious which may be a question for the sender. – Pimp Juice IT Sep 20 '16 at 12:23
  • 2
    Have you confirmed that the .asc file is actually a PGP signature? Open it with a text editor to be sure. – grawity Sep 20 '16 at 12:33
  • WOW! i Opened the .asc file with a text editor and it worked! well, at least a pgp message i had sent to me in an asc file decrypted, i haven't tried verifying the files i gave as examples in original question yet tho, so here comes the natural followup, assuming i can always convert everything to text and manually decrypt or verify it, shouldn't i not have to do that? why can't i just click on the asc file, gpg should fire up and do its thing right? whats the problem then? – bloomlsu Sep 21 '16 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.