When I enter the command line arp -d * at an instance of cmd.exe, I get

The ARP entry deletion failed: The parameter is incorrect

I can delete individual entries fine, e.g. arp -d

I also have Cygwin and Git Bash installed, so I thought maybe the * was getting expanded like in a Unix shell, but it doesn't appear so, as echo * from cmd.exe results in a simple * output. I have also tried escaping the asterisk and enclosing it in quotes with arp -d "*" and arp -d ^*. Both result in the same error.

I do have two NICs on this machine, an internal and a USB, but I get the same error when I unplug the USB NIC.

The account I am running from is an administrator, and I have also tried right-clicking cmd.exe and selecting "Run as Administrator."

  • 1
    Same result confirmed on Win10 Pro. – mt025 Sep 20 '16 at 18:58
  • Hm, is this something I just haven't noticed yet on Win7? The '*' wildcard is supposed to be supported according to the arp -help documentation, and it used to work in XP... – Sam Skuce Sep 20 '16 at 19:01
  • 1
    This happened to me on two HP machines that I recently restored to the original factory settings. All of the other machines of the same model had no issues with this command. This was using Windows 10. – kojow7 Oct 23 '18 at 20:03

Use the command netsh interface ip delete arpcache

You can then run arp -a to confirm that the entries have gone.

Clear, Delete and Refresh ARP Cache Entry

  • Yes, that works thanks! I'm going to leave the question open for now though, since the arp command line utility is supposed to work as well, and there's not good reason for them to break something that used to work... – Sam Skuce Sep 20 '16 at 19:03

I tried delete the ARP Cache with the arp -d command and showed me "The ARP entry deletion failed: The parameter is incorrect" then I tried with netsh interface ip delete arpcache command and it worked and then I tried with the arp -d command again and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.