Is it possible to reboot the Ubuntu sub-system without restarting my system?

I tried to use the shutdown command after installing some updates, but that doesn't seem to be an option here.

Bash on Windows. Reboot required. shutdown: Unable to shutdown system


Shutdown everything: Build 18917+

wsl.exe --shutdown

Terminate specific distro: Windows 1903+

wsl.exe -t <DistroName>

Older versions

# PowerShell (admin)
Restart-Service LxssManager

# or CMD (admin)
net stop LxssManager
net start LxssManager

enter image description here

  • why net instead of sc, as in @llinfeng's answer – Gaia Jan 1 '19 at 17:36
  • net worked in cmd (with admin). Just tested that my bat-file with sc did not work in Windows OS Build 1809. – llinfeng Jan 15 '19 at 16:11
  • @Gaia the net command is the legacy tool for managing Windows services and networks, pre-PowerShell – Stabledog Dec 7 '19 at 13:21
  • I had issues in an Admin CMD on my machine (Windows 10 build 17763) with the net command (net stop LxxManager seems to hang). Since I stay away from PowerShell (since I have WSL), the sc command (query/stop/start) get the job done without any issues on that same Admin CMD window. I think it currently is the preferred API for the Service Control Manager? – Flandraco Apr 10 '20 at 0:45
  • 1
    Working perfectly with wsl2 ! – robe007 Jul 3 '20 at 19:46

At an administrative PowerShell prompt: Restart-Service LxssManager

  • 15
    @RajeshS It may be short but it does answer the question. – nyuszika7h Apr 21 '19 at 14:41
  • 1
    I like it. Easy to remember, autocompletes with tab well enough. Amusing to see how well Windows got its service model down right from the beginning. – Louis Waweru Apr 24 '19 at 1:43
  • 14
    I just get this repeatedly WARNING: Waiting for service 'LxssManager (LxssManager)' to stop... – Chris Snow Jun 13 '19 at 15:53
  • 4
    This works perfectly. Just start your powershell with admin rights first. – Erik Kalkoken Nov 1 '19 at 13:21
  • I have the same issue to Chris. – pupsozeyde Jun 4 at 5:02

Since Windows 10 version 1803, closing all WSL terminal windows won't kill background processes by default, unless the file /var/run/reboot-required is present. This file will be automatically created by apt on Ubuntu when an update requires a reboot, but if you want to manually reboot the subsystem, you can create the file yourself:

sudo touch /var/run/reboot-required

I haven't tested this on other distributions available in the Microsoft Store. An alternative solution is to kill all processes yourself:

sudo killall -r '.*'
  • Do you know what I can do force a required reboot? I want to test the answer so I can accept it. – Louis Waweru Jun 10 '18 at 4:37
  • 1
    This worked for me. I had to sudo: sudo killall -r '.*' – F21 Jun 20 '18 at 9:19
  • 1
    @Louis I see you've already accepted it, but you can do sudo touch /var/run/reboot-required. In fact, it seems the presence of the file causes WSL to kill all background processes and shut down the subsystem when all terminal windows are closed, so you can abuse that as well. – nyuszika7h Jul 28 '18 at 8:40
  • 1
    killall worked perfectly for me. Didn't need to touch reboot-required. – Giovanni Bassi May 5 '19 at 16:06
  • Touching reboot-required (and closing all terminals) didn't do anything for me. In the end, I just did wsl --shutdown and wsl -d <Distro> (example: wsl -d Ubuntu; to get the list, use wsl -l). – ADTC Jun 10 at 22:10

Just open a cmd window as adminstrator and run these commands to restart it.

net stop LxssManager
net start LxssManager
  • 1
    Add some seconds between those two command. e.g. timeout /t 3 command (add 3 seconds). – Biswapriyo Oct 21 '18 at 6:33
  • 2
    This duplicates samdd's answer from August. – fixer1234 Oct 25 '18 at 2:46
  • Doesn't work... stays in "stopping" status. when I try to run it again I get "The service is starting or stopping. Please try again later."... never finishes. Always hangs after I run an rsync command from batch like "bash -c 'rsync....'". This is a nightmare. – gunslingor Jun 5 '19 at 13:37
  • 1
    "The LxssManager service is stopping......................................................................... The LxssManager service could not be stopped." :-/ – Alex Jansen Nov 25 '19 at 23:26

Simply exiting the shell with exit and reopening seems to do the trick. The shell needs to be run as admin.

Louis@ATHENA:~$ bin/rcheck.sh
Reboot not necessary.

Louis@ATHENA:~$ bin/update.sh
[sudo] password for Louis:
The following packages will be upgraded:
  libssl1.0.0 openssl
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libssl1.0.0 amd64 1.0.1f-1ubuntu2.21 [830 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ trusty-updates/main openssl amd64 1.0.1f-1ubuntu2.21 [489 kB]
Setting up libssl1.0.0:amd64 (1.0.1f-1ubuntu2.21) ...
Setting up openssl (1.0.1f-1ubuntu2.21) ...
Del libssl1.0.0 1.0.1f-1ubuntu2.20 [830 kB]
Del openssl 1.0.1f-1ubuntu2.20 [489 kB]

Louis@ATHENA:~$ bin/rcheck.sh
Reboot required.

Louis@ATHENA:~$ exec bash -l
Louis@ATHENA:~$ bin/rcheck.sh
Reboot required.

Louis@ATHENA:~$ exit

Louis@ATHENA:~$ bin/rcheck.sh
Reboot not necessary.
  • 6
    This does not work anymore. – Dakkaron Jul 24 '18 at 9:51
  • @Dakkaron - It did when the question was submitted. – Ramhound Oct 23 '18 at 1:55
  • 3
    That's why I said "anymore". The information that this post is outdated is important, so other people who have the problem right now don't need to try it to find out that it does not work. I am not sure how things are handled here, but on Stackoverflow an answer is not only supposed to help the person who asked the question, but also all others who are looking for solutions for the same problem. – Dakkaron Oct 23 '18 at 8:23
  • 1
    Works for me on build 17134. – Ian Kemp Nov 8 '18 at 7:19
  • 1
    Worked for me on 1909 (18363). So the answer is still valid. Make sure you run it in an elevated prompt. – Will I Am Feb 23 '20 at 1:01

The following allows a shutdown from within WSL2 using the command wslreboot (or any custom command).

Technically, wslshutdown would be more appropriate for the code below:

Create alias:

sudo nano ~/.bash_aliases

Add line:

alias wslreboot='history -a && cmd.exe /C wsl --shutdown'

history -a ensures that the bash command history us saved before shutdown.

Enable Alias:

Restart WSL

cmd.exe /C wsl --shutdown

or type

source .bash_aliases


now you can type


to shutdown

I'm thinking you could use a variation of the above to run a batch file with the lines:

wsl --shutdown

for a proper restart.


I have created a *.bat file, and running it does the rebooting within 10 seconds. (I am amazed by how fast things get reloaded. And, please advise if my approach will cause serious trouble in the long run.)

Put the following two lines in a WSL_reboot.bat file, and run it every time you need to reboot the WSL on Windows 10.

net stop LxssManager
net start LxssManager 

Update note: per my recent "upgrade" of Windows OS, the Build 1809 does not like sc command anymore.

Side note: one need to reboot the WSL "kernel" when he/she format a lettered-drive through Windows Explorer. Haven't quite solve the by-product, though, where ls command will get the following error. Related-post-from-WSL@Github; Related-post-from-the-Stack. Will drop a link if I manage to solve the by-product bug.

ls: 'System Volume Information': Permission denied
d--x--x--x 1 llinfeng llinfeng       512 Jan 15 11:00 'System Volume Information'/
  • why sc instead of net, as in @samdd's answer – Gaia Jan 1 '19 at 17:35
  • 1
    I guess net was not working with my Windows 10 at the time? sc must have worked back then. I should have specified the windows build number. – llinfeng Jan 2 '19 at 16:56

What I have done is:

  • Enter this command in the command line you've opened in Admin mode: wsl.exe --install
  • Restart your machine

Then Windows will be updated accordingly. After that, the error gone. The Linux account can be created normally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.