343

Is it possible to reboot the Ubuntu sub-system without restarting my system?

I tried to use the shutdown command after installing some updates, but that doesn't seem to be an option here.

Bash on Windows. Reboot required. shutdown: Unable to shutdown system

1
  • Rebooting (standard) WSL is not a thing. Simply put, a WSL distribution is just a container (like Docker) with a shell. Even with WSL 2, rebooting the VM does nothing to a distribution.
    – Daniel B
    Jun 2 at 10:46

8 Answers 8

491

You cannot reboot a distro with a single command. You must shut down and boot up the distro with two commands.

View the list of distros and their current state:

wsl -l -v

Shutdown everything: Build 18917+

wsl --shutdown

Terminate a specific distro: Windows 1903+

wsl -t <DistroName>

Boot up the default distro (marked with *):

wsl

Boot up a specific distro:

wsl -d <DistroName>

Older versions

# PowerShell (admin)
Restart-Service LxssManager

# or CMD (admin)
net stop LxssManager
net start LxssManager

enter image description here

11
  • why net instead of sc, as in @llinfeng's answer
    – Gaia
    Jan 1, 2019 at 17:36
  • net worked in cmd (with admin). Just tested that my bat-file with sc did not work in Windows OS Build 1809.
    – llinfeng
    Jan 15, 2019 at 16:11
  • @Gaia the net command is the legacy tool for managing Windows services and networks, pre-PowerShell
    – Stabledog
    Dec 7, 2019 at 13:21
  • 1
    I'm using the newest Windows Insider with WSL 2 and tried to use commands like C:\Users\xxx>wsl -l -v showing that three are "Ubuntu", "docker-desktop" and "docker-desktop-data" As in my case, there is also the newest docker running so wsl -shutdown works, but it also closes my docker environment After trial and error, I found that wsl -t "Ubuntu" works, but sometimes it takes time or is not reliable? Once it worked when I started command shell with admin rights. May 14, 2020 at 1:42
  • 2
    Working perfectly with wsl2 !
    – robe007
    Jul 3, 2020 at 19:46
103

At an administrative PowerShell prompt: Restart-Service LxssManager

7
  • 17
    @RajeshS It may be short but it does answer the question.
    – nyuszika7h
    Apr 21, 2019 at 14:41
  • 1
    I like it. Easy to remember, autocompletes with tab well enough. Amusing to see how well Windows got its service model down right from the beginning. Apr 24, 2019 at 1:43
  • 17
    I just get this repeatedly WARNING: Waiting for service 'LxssManager (LxssManager)' to stop...
    – Chris Snow
    Jun 13, 2019 at 15:53
  • 4
    This works perfectly. Just start your powershell with admin rights first. Nov 1, 2019 at 13:21
  • I have the same issue to Chris. Jun 4, 2021 at 5:02
40

Since Windows 10 version 1803, closing all WSL terminal windows won't kill background processes by default, unless the file /var/run/reboot-required is present. This file will be automatically created by apt on Ubuntu when an update requires a reboot, but if you want to manually reboot the subsystem, you can create the file yourself:

sudo touch /var/run/reboot-required

I haven't tested this on other distributions available in the Microsoft Store. An alternative solution is to kill all processes yourself:

sudo killall -r '.*'
6
  • Do you know what I can do force a required reboot? I want to test the answer so I can accept it. Jun 10, 2018 at 4:37
  • 1
    This worked for me. I had to sudo: sudo killall -r '.*'
    – F21
    Jun 20, 2018 at 9:19
  • 1
    @Louis I see you've already accepted it, but you can do sudo touch /var/run/reboot-required. In fact, it seems the presence of the file causes WSL to kill all background processes and shut down the subsystem when all terminal windows are closed, so you can abuse that as well.
    – nyuszika7h
    Jul 28, 2018 at 8:40
  • 1
    killall worked perfectly for me. Didn't need to touch reboot-required. May 5, 2019 at 16:06
  • Touching reboot-required (and closing all terminals) didn't do anything for me. In the end, I just did wsl --shutdown and wsl -d <Distro> (example: wsl -d Ubuntu; to get the list, use wsl -l).
    – ADTC
    Jun 10, 2021 at 22:10
23

Just open a cmd window as adminstrator and run these commands to restart it.

net stop LxssManager
net start LxssManager
4
  • 2
    Add some seconds between those two command. e.g. timeout /t 3 command (add 3 seconds).
    – Biswapriyo
    Oct 21, 2018 at 6:33
  • 2
    This duplicates samdd's answer from August.
    – fixer1234
    Oct 25, 2018 at 2:46
  • Doesn't work... stays in "stopping" status. when I try to run it again I get "The service is starting or stopping. Please try again later."... never finishes. Always hangs after I run an rsync command from batch like "bash -c 'rsync....'". This is a nightmare.
    – gunslingor
    Jun 5, 2019 at 13:37
  • 3
    "The LxssManager service is stopping......................................................................... The LxssManager service could not be stopped." :-/ Nov 25, 2019 at 23:26
12

The following allows a shutdown from within WSL2 using the command wslreboot (or any custom command).

Technically, wslshutdown would be more appropriate for the code below:

Create alias:

sudo nano ~/.bash_aliases

Add line:

alias wslreboot='history -a && cmd.exe /C wsl --shutdown'

history -a ensures that the bash command history us saved before shutdown.

Enable Alias:

Restart WSL

cmd.exe /C wsl --shutdown

or type

source .bash_aliases

Use

now you can type

wslreboot  

to shutdown


I'm thinking you could use a variation of the above to run a batch file with the lines:

wsl --shutdown
wsl

for a proper restart.

3
  • I wasted precious minutes reading documentation and figuring this out on my own before finding your answer :) Thanks Mar 28 at 2:45
  • Nice answer, learned something new. Jun 29 at 2:08
  • Actually, PowerShell 7 detects the abrupt exit as an error. Jul 12 at 11:40
11

Simply exiting the shell with exit and reopening seems to do the trick. The shell needs to be run as admin.

Louis@ATHENA:~$ bin/rcheck.sh
Reboot not necessary.

Louis@ATHENA:~$ bin/update.sh
[sudo] password for Louis:
The following packages will be upgraded:
  libssl1.0.0 openssl
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libssl1.0.0 amd64 1.0.1f-1ubuntu2.21 [830 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ trusty-updates/main openssl amd64 1.0.1f-1ubuntu2.21 [489 kB]
Setting up libssl1.0.0:amd64 (1.0.1f-1ubuntu2.21) ...
Setting up openssl (1.0.1f-1ubuntu2.21) ...
Del libssl1.0.0 1.0.1f-1ubuntu2.20 [830 kB]
Del openssl 1.0.1f-1ubuntu2.20 [489 kB]

Louis@ATHENA:~$ bin/rcheck.sh
Reboot required.

Louis@ATHENA:~$ exec bash -l
Louis@ATHENA:~$ bin/rcheck.sh
Reboot required.

Louis@ATHENA:~$ exit

Louis@ATHENA:~$ bin/rcheck.sh
Reboot not necessary.
Louis@ATHENA:~$
7
  • 10
    This does not work anymore.
    – Dakkaron
    Jul 24, 2018 at 9:51
  • @Dakkaron - It did when the question was submitted.
    – Ramhound
    Oct 23, 2018 at 1:55
  • 6
    That's why I said "anymore". The information that this post is outdated is important, so other people who have the problem right now don't need to try it to find out that it does not work. I am not sure how things are handled here, but on Stackoverflow an answer is not only supposed to help the person who asked the question, but also all others who are looking for solutions for the same problem.
    – Dakkaron
    Oct 23, 2018 at 8:23
  • 1
    Works for me on build 17134.
    – Ian Kemp
    Nov 8, 2018 at 7:19
  • 1
    Worked for me on 1909 (18363). So the answer is still valid. Make sure you run it in an elevated prompt.
    – Will I Am
    Feb 23, 2020 at 1:01
4

I have created a *.bat file, and running it does the rebooting within 10 seconds. (I am amazed by how fast things get reloaded. And, please advise if my approach will cause serious trouble in the long run.)

Put the following two lines in a WSL_reboot.bat file, and run it every time you need to reboot the WSL on Windows 10.

net stop LxssManager
net start LxssManager 

Update note: per my recent "upgrade" of Windows OS, the Build 1809 does not like sc command anymore.

Side note: one need to reboot the WSL "kernel" when he/she format a lettered-drive through Windows Explorer. Haven't quite solve the by-product, though, where ls command will get the following error. Related-post-from-WSL@Github; Related-post-from-the-Stack. Will drop a link if I manage to solve the by-product bug.

ls: 'System Volume Information': Permission denied
...
d--x--x--x 1 llinfeng llinfeng       512 Jan 15 11:00 'System Volume Information'/
...
2
  • why sc instead of net, as in @samdd's answer
    – Gaia
    Jan 1, 2019 at 17:35
  • 1
    I guess net was not working with my Windows 10 at the time? sc must have worked back then. I should have specified the windows build number.
    – llinfeng
    Jan 2, 2019 at 16:56
0

What I have done is:

  • Enter this command in the command line you've opened in Admin mode: wsl.exe --install
  • Restart your machine

Then Windows will be updated accordingly. After that, the error gone. The Linux account can be created normally.

1
  • I'm not sure what you're trying to say, but this doesn't remotely answer the question. The OP already has WSL installed, and merely wanted a way to reboot the Linux subsystem without going through a full Windows reboot.
    – Auspex
    Sep 7 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.