0

Today I installed the CM Hyper 212 EVO CPU cooler in my computer. It went rather smoothly but afterwards my PC wouldn't start up anything. Not even beeps.

I have tried resetting BIOS, re-seating all cables, turning on without GPU, putting back the old cooler, nothing. So my PC already had issues with crashing under load (sometimes) so I figured it completely went dead in between yesterday and turning on today after installing the new cooler.

So I figured the PSU is failing, I tested if it would power anything at all by disconnecting it from everything(except the wall) and connecting two pins on the 24pin connector so the Fan would receive power. That worked, it started spinning. But when connected to everything in my PC nothing happens, not even the PSU's fan or any leds.

So now I am wondering if it is a motherboard failure or PSU failure. Basically I am looking for some kind of confirmation on which part it is. I don't have any spare parts or a meter to test the PSU's wattage or something.

My PC specs are:

  • GPU: MSI Nvidia GTX970 4GB
  • CPU: AMD FX-8350 @ 4Ghz
  • Motherboard: MSI 970 Gaming
  • RAM: Corsair Vengeance 2x4GB DDR3 1800MHz (running at 1333Mhz)
  • PSU: Corsair CX750M, 750 watt.
  • SSD: Samsung 850 EVO 250GB
  • HDD: WD Black 1TB
  • OS: Windows 10 Pro 64bit

P.S. There's a sort of oily liquid leaking on my motherboard, although after googeling I kept reading it's "normal" and I wouldn't have to worry about it.

6
  • 1
    We can't confirm it for you (beyond guessing). If you suspect the PSU, get a known-good PSU and test with it. I can tell you though, that there shouldn't be any "oily liquid leaking" on your motherboard. – Ƭᴇcʜιᴇ007 Sep 21 '16 at 18:07
  • "There's a sort of oily liquid leaking on my motherboard" - I am not sure what you read, you didn't provide that information, but an oily liquid should not be on your motherboard. If I were to hazard a guess, the reason your computer no longer starts, is because of that liquid. Despite it being oily, it could have caused a short, depending on the properties of the liquid. There is a difference between the liquid hitting a CPU's lid, and the liquid touching, every other unprotected IC on the motherboard – Ramhound Sep 21 '16 at 18:11
  • Do any of the capacitors look like they have broken open? The only thing other than water cooling that might cause an 'oily liquid' could be if a electrolydic capacitor exploded or started leaking for some reason. Here is an example of what that MIGHT look like community.klipsch.com/uploads/monthly_10_2013/… – Richie086 Sep 21 '16 at 18:18
  • I am quite interested in where you read about an oily liquid being on your motherboard being "normal". Do you have a link to the site where you found this info? – Richie086 Sep 21 '16 at 18:20
  • @Richie086 Regarding where I read about it being "normal" here, here and here. Also, no the capacitors are normal. That was what I checked first. The images provided on the links are exactly what I have. I've had it for a while, noticed it a month ago when I had shutdown under load issues. It was fixed by re-seating the CPU power cable though. – Quwin Sep 21 '16 at 18:36
1

Oke, my PC starts up again. I don't really know why.

I basically reassembled my PC again since I was testing out all the different components. And nothing pointed at anything conclusive. So after reassembling and just trying again for no reason, it booted. Everything is working fine now.

Regarding the "liquid" I am going to clean this off and when I still encounter issues I will RMA that.

Thanks for the responses! ;)

2
  • When you reassembled it, did you build everything out of the case first? I've had issues with misaligned motherboard posts causing grounding issues. Also if you are not careful you may have dropped a screw or something metal between the case and the motherboard. Who knows, what matters is you have a working machine again! – Richie086 Sep 21 '16 at 23:28
  • @Richie086 No, I had kept the motherboard in place, disconnected all cables to the power supply and just did a few tests on the power supply and cleaned a bit of dust off. Afterwards I just reconnected every cable and it just worked. – Quwin Sep 23 '16 at 23:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.