0

I was trying to help a friend with a printer problem—running Windows 7 Home Premium, with an HP Color LaserJet Pro MFP M277dw.

The printer was not printing. Even attempting to open the "Print" dialog from Windows notepad would give an error and crash the program. Attempting to access information about the printer from "printer properties" would give an error with "C:\Windows\Explorer.exe" in the title bar; I didn't copy it down but it had some computer pointers in it (i.e. very low level).

I tried the following:

  • Attempted to remove the printer; printer icon didn't go away.

  • Attempted the solution described in this comment; was unable to remove the printer driver because it was in use.

  • Rebooted the computer into safe mode (with networking) and followed these steps to remove the registry entries related to the printer. On the last step, I didn't remove the "inf" files (just the registry entries), because there were so many "inf" files and I couldn't tell which (if any) referenced the printer we are having trouble with.

  • Booted the computer up normally, and checked the printers list. The printer was removed (yay!) and notepad could successfully open the print dialog, but complained that no printers are installed.

Then, we tried adding the printer again through the "add printer" dialog. We clicked "add network printer" and chose the correct printer (with the correct IP address) from the list.

The printer installed but then the installer crashed.

The printer icon had not appeared. We clicked "add printer" again and got the error: "Windows can't open Add Printer. The local print spooler service is not running. Please restart the spooler or restart the machine."

The printer icon did briefly appear, and didn't disappear when we attempted to remove it, but is currently not listed. Notepad successfully opens the print dialog box but there are no printers available (none installed).


I think there is a corrupt driver involved.

How can I get rid of the errors when I try to install this printer (maybe wipe out the driver completely?) and then successfully reinstall it?

More simply, how can I get this printer reinstalled correctly and working again?

  • 1
    Device and Printers-> select any printer->Print Server properties(on top tool bar)->Drivers(tab). Select the old driver, click remove, and select Remove driver and driver package. Goto hp.com, and download the newest drivers and see if that helps. I recommend HP Universal Print Driver for Windows PostScript (64-bit) driver which always works for me. – cybernard Sep 22 '16 at 3:38
  • How your friend's MFP (as it's not only printer, but also a scanner) is connected to the computer (USB, Wi-Fi or ethernet (cable))? – alljamin Sep 22 '16 at 3:44
  • @cybernard, although there are now no printers in that view at all, I do recall that we tried that (before we went to regedit). It said the driver couldn't be removed as it was in use, or words to that effect. I'm pretty sure that's the option we got to from printui /s, and then when we tried printui /s from safe mode, it said it couldn't be launched as the print spooler wasn't running (catch 22). (cont'd) – Wildcard Sep 22 '16 at 3:45
  • (cont'd) That's when we followed these steps to edit the registry, as I linked to from the question. – Wildcard Sep 22 '16 at 3:45
  • 1
    pnputil -d printer.inf /force If you can find the driver inf name you can use this to remove it. This should help you find it. dism /online /get-drivers /format:table You can also boot a Windows CD bring up command prompt, and use this offline method. dism /Image:c:\ /Remove-Driver /Driver:OEM1.inf NOTE: it may not be the C: drive in this condition, and you need the drive with the windows folder on it. – cybernard Sep 22 '16 at 4:03
0

The problem is fixed now. Below is what I did to fix it (after the steps attempted that I listed in the question).

I attempted loading the registry keys for the print spooler from a working Windows 7 machine (see comment from "WindowsAdminGuru") and rebooting the computer, but there was no evident change and I don't think that was the solving factor.

What did make a difference was twofold:

First, I followed the steps listed here to:

  • Stop the print spooler (which was actually already stopped) through Windows-R -> cmd -> services.msc -> print spooler -> stop.
  • Delete all files from the three directories C:\Windows\system32\spool\drivers\w32x86, C:\Windows\system32\spool\printers, and C:\Windows\system32\spool\drivers\x64, although in my case there were only files present in the third of these, x64.
  • Start the print spooler (from the window which I already had open, but which was accessed through Windows-R -> cmd -> services.msc -> print spooler -> start.)

This made a change, and I was then able to download the drivers from the manufacturer and install the printer again. (The driver didn't show up in "Windows Update," which froze, but I successfully downloaded it through Google Chrome and ran the installer/setup wizard with no trouble.)

But, although I successfully got a test page printed, weird things continued to happen:

Three printers showed up in the "Printers and Devices" window, two duplicates of the printer we wanted, plus a "Fax" version of the same printer name but with a different icon. None of them worked. When I tried to print from Notepad, I got a different error and then the print spooler quit (and all the printers disappeared from the list). I'd kept services.msc open and I tried starting it, but it quit again.

On one of these tries I got error 1067. Googling that, I found and followed directions to:

  • Stop the print spooler (which was already stopped)
  • Remove every registry key from hkey_local_machine -> system -> currentcontrolset -> control -> print -> providers, except for "Internet Print Provider" and "LanMan Print Services" (which in my case were the only two there)
  • Remove every registry key from hkey_local_machine -> system -> currentcontrolset -> control -> print -> printers. This had one entry, which was the printer we'd been having so much trouble with! I removed it.
  • Restart the print spooler (from services.msc which I still had open).

Print spooler didn't die again this time.

Next I went to the "Add Printer" dialogue, which also didn't die (so far so good!) and clicked "Add local printer" (Note: The "Add network printer" option was not present at all!), then "Use an existing port," chose the standard TCP/IP port already listed that the printer was on, then received a choice:

It said that the printer driver was already installed, and I had the choice to use the installed driver, or reinstall the driver. I chose "reinstall the driver." That took several minutes.

With that completed, the printer is now working perfectly with no hitches. :)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.