1

I've got a few font files (.ttf) lying around from a directory I deleted, I've been trying to delete them but it's really not working, this is what I've tried so far and what the results were

Deleting in explorer:
Require Admin Permissions

Deleting in cmd
Access Denied

Deleting in explorer as admin
File is open in system

Deleting in cmd as admin
Access Denied

Killing explorer and deleting in cmd
Access Denied

Deleting with file assassin:
Corrupted File? I can't remove it, and notepad++ tells me the file doesn't exist, it is definitely different than the others, but I'm not sure how.

I really hate having these files stuck in my system, is there anything else that I should be trying to get rid of these files?

Thanks for your time.

2 Answers 2

2

Open the Fonts folder located at C:\Windows\Fonts Right-click the font you want to remove, and click Delete

If that doesn't work, you may have to edit the registry to remove the font references before deleting the .TTF files (on next reboot)

Registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts

See "Uninstalling a Font Manually Using Regedit" @ How to Reset Default System Font Settings (to Segoe UI) in Windows?

3
  • This didn't work, to be clear these aren't fonts in the C:\Windows\Fonts, they came from an IDE called CrossCore Embedded Studio, I am trying to delete it and the font files cannot be removed. I did find the registry keys for the fonts, deleted them and rebooted, but I still cannot delete the fonts in explorer or cmd. I get "Open in System" in explorer and "Access Denied" in cmd
    – Velvacaine
    Sep 22, 2016 at 14:16
  • It's possible that a service may be using the .ttf. Run Process Explorer and see which process is using the .ttf file.
    – w32sh
    Sep 22, 2016 at 17:12
  • I'm with @w32sh.. either the system has open handles to these files, or you lack the permissions to remove them. If ProcessExplorer shows open handles, you can close them right there within ProcessExplorer and delete after. If that isn't the problem, you will need to take ownership of them. Lastly, when all else fails, try safe mode. May 14, 2019 at 15:12
0

Have you tried MoveFile? It'll schedule the file to be deleted at the next reboot, before any process can get their claws in it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.