2

I am trying to get a Windows 10 virtual machine inside Hyper-V to automatically login (without any lock screen or user password input). There are similar questions on SU about doing this in Windows 10, but I believe that the Windows 10 build 10586.545 may require some additional registry changes.

  1. This is a clean Windows 10 build 10586.545 install.

  2. I ran netplwiz as shown in the image below, unchecking the checkbox "Users must enter a user name and password to use this computer".

  3. I also tried changing options in registry.

Resources used: forum post from 2015

What I get is that the Windows lock screen still appears and I am prompted for a password. What I expected was that Windows would let me automatically sign in, and that I would get directly to the desktop of windows (not the lock/login screen) when I watch the system boot up in the Virtual Machine Connection window.

I have verified that I entered the password and username correctly in the automatically sign in dialog which appeared.

windows 10 screenshot showing start run netplwiz dialog

Update: My VM spontaneously updated to build 14393 (from build 10586.x) and the problem remains. I also tried AutoLogon sysinternals tool, and that doesn't work either.

Update: It wasn't what I expected. Hyper-V Virtual Machine "Enhanced" Connection really actually means it makes an RDP connection to the VM. This interferes with the user observing the real root session since the Hyper-V Virtual Machine Connection works via RDP, if Enhanced is on.

  • How you do this is exactly the same, as how you did it on Windows 7, Windows 8, Windows 8.1, and previous major builds of Windows 10. I hope you realize that, 10586.545, is Version 1511 not Version 1607 (build 14393.xx), – Ramhound Sep 22 '16 at 15:58
  • How you defeat the Lockscreen that appears, when you make a RDP connection, is an entirely different battle sadly. One I don't know how to perform, one you might not want to defeat, depending on your security posture. – Ramhound Sep 22 '16 at 17:00
  • You should cleanup the comments, the question, and then submit an answer to your question ;-) – Ramhound Sep 22 '16 at 17:06
2

I found it confusing, because I had forgotten this fact, that Hyper-V when it shows you the "screen" of your virtual machine is not in fact, giving you a glimpse of some hardware VGA driver buffer (the "real" monitor of the virtual machine) but is instead, by default, using an Enhanced integration.

The enhanced integration in windows vmconnect.exe in essentially uses the same technique as Remote Desktop client for Windows (mstsc) uses. This causes users like me to think that the autologon feature isn't working, but in fact it is working.

In order to observe the VM logging in on its own, turn off Hyper-V Enhanced Session from the View menu of your Virtual Machine Connection (vmconnect.exe) window.

  • Tanks a lot - this should be marked as the correct answer. After hours of trying to get autologin to work, I found your solution and it's working. – Maecky Nov 25 '17 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.